summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-09-06 20:14:38 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-09-06 20:54:27 +0300
commit927088615eb663010baa5c66d920363d93da1035 (patch)
treef6b63d3f9798fa8d8a2df153c2520b7d86f60447 /dev-python/python-cstruct
parentdev-python/cfn-lint: add 0.64.0 (diff)
downloadgentoo-927088615eb663010baa5c66d920363d93da1035.tar.gz
gentoo-927088615eb663010baa5c66d920363d93da1035.tar.bz2
gentoo-927088615eb663010baa5c66d920363d93da1035.zip
dev-python/python-cstruct: add 3.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/python-cstruct')
-rw-r--r--dev-python/python-cstruct/Manifest1
-rw-r--r--dev-python/python-cstruct/python-cstruct-3.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/python-cstruct/Manifest b/dev-python/python-cstruct/Manifest
index 636836e5e0e4..0e27bc491e7a 100644
--- a/dev-python/python-cstruct/Manifest
+++ b/dev-python/python-cstruct/Manifest
@@ -1,2 +1,3 @@
DIST python-cstruct-2.2.gh.tar.gz 18764 BLAKE2B 75aaffae27fef59799e52866f8169cc5d7362ef1553a56986f361ef7cfb7ca3e7d8c67fe0f112ec8e03ddacf45885e19fc1ce0d9d27c7581deafbf7e7fe1789b SHA512 5a1d62b596fef08a48020557e82fc81360430d94f18ce0667919815d57b944102067c2fe5723372616f73c995afd3a1f674e4a37e406d0dc7eeaf9fe3ef8f484
DIST python-cstruct-2.3.gh.tar.gz 19043 BLAKE2B dd445da91d155dc576523d5c15dc963493dfb62e7e79fae6c436e69654432eadbc30b0001026f5613268800eb0a3a01392120b11e7b3995cff16477850818c9f SHA512 5700a3d8ef58130bc5b3b5d7c36102f6a878fd8d5b9104804f0c206e583e77d7a9c9ff8e8008d9bd1ee72d55167e48cd3f9ba776816eb25ceb8ceaf0c880b597
+DIST python-cstruct-3.0.gh.tar.gz 25950 BLAKE2B 7ea8c77ed87e4fb740c3f7a4ed53a7532ee5aca15ee46fbb40da7308ae62ceacd7ccc67a958e6355904604ae67c9594acc9cae5d18bfed0558b91f7e9c8ad0a9 SHA512 dd1c85363512edc4df0379dec40e7d7fe3ceff1cc4014eae8dab0e91c47ea9c3619211e1a637aeec134ce713d0681688630b7fde97f02c6bcd7103a32f258a73
diff --git a/dev-python/python-cstruct/python-cstruct-3.0.ebuild b/dev-python/python-cstruct/python-cstruct-3.0.ebuild
new file mode 100644
index 000000000000..7b8d01c50942
--- /dev/null
+++ b/dev-python/python-cstruct/python-cstruct-3.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+inherit distutils-r1
+
+DESCRIPTION="C-style structs for Python"
+HOMEPAGE="https://github.com/andreax79/python-cstruct
+ https://pypi.org/project/cstruct/"
+SRC_URI="
+ https://github.com/andreax79/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( README.md )
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ sed -e "/find_packages(/s@exclude=\[@&'tests', @" -i setup.py || die
+}