summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGábor Oszkár Dénes <gaboroszkar@protonmail.com>2022-03-08 21:36:20 +0100
committerSam James <sam@gentoo.org>2022-07-15 03:11:57 +0100
commit199dd6a3fe469909a0aab1ffc9fb51f0c369b62c (patch)
tree7df2e0fd2fb90a298901c4d55ed9d5483ecef8e4 /dev-python/python-constraint/python-constraint-1.4.0.ebuild
parentdev-python/pylatexenc: new package (diff)
downloadgentoo-199dd6a3fe469909a0aab1ffc9fb51f0c369b62c.tar.gz
gentoo-199dd6a3fe469909a0aab1ffc9fb51f0c369b62c.tar.bz2
gentoo-199dd6a3fe469909a0aab1ffc9fb51f0c369b62c.zip
dev-python/python-constraint: new package
Closes: https://bugs.gentoo.org/834768 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Gábor Oszkár Dénes <gaboroszkar@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/python-constraint/python-constraint-1.4.0.ebuild')
-rw-r--r--dev-python/python-constraint/python-constraint-1.4.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/python-constraint/python-constraint-1.4.0.ebuild b/dev-python/python-constraint/python-constraint-1.4.0.ebuild
new file mode 100644
index 000000000000..e7a17dd7f275
--- /dev/null
+++ b/dev-python/python-constraint/python-constraint-1.4.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Constraint Solving Problem resolver for Python"
+HOMEPAGE="https://github.com/python-constraint/python-constraint"
+SRC_URI="https://github.com/python-constraint/python-constraint/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+PATCHES=(
+ "${FILESDIR}/python-constraint-1.4.0-exclude-examples.patch"
+)
+
+distutils_enable_tests pytest