summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2020-12-01 18:12:48 +0100
committerLouis Sautier <sbraz@gentoo.org>2020-12-01 18:51:13 +0100
commitcb9604994fcb1542ffe91178b75ecf5b1a0d80cf (patch)
tree92c63fe0ecce223943c09e713698efeed334f722 /dev-python/pytest-xdist
parentx11-misc/xsnow: Adopt (diff)
downloadgentoo-cb9604994fcb1542ffe91178b75ecf5b1a0d80cf.tar.gz
gentoo-cb9604994fcb1542ffe91178b75ecf5b1a0d80cf.tar.bz2
gentoo-cb9604994fcb1542ffe91178b75ecf5b1a0d80cf.zip
dev-python/pytest-xdist: fix tests with setuptools>49
The new --via-root option for distutils_install_for_testing fixes tests with setuptools>49 when the package isn't installed. One test is still broken at the moment but it's an upstream issue so we're skipping it for now. Closes: https://bugs.gentoo.org/757591 Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'dev-python/pytest-xdist')
-rw-r--r--dev-python/pytest-xdist/pytest-xdist-2.1.0.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/dev-python/pytest-xdist/pytest-xdist-2.1.0.ebuild b/dev-python/pytest-xdist/pytest-xdist-2.1.0.ebuild
index de9789a944b9..27e096bc9919 100644
--- a/dev-python/pytest-xdist/pytest-xdist-2.1.0.ebuild
+++ b/dev-python/pytest-xdist/pytest-xdist-2.1.0.ebuild
@@ -32,6 +32,10 @@ BDEPEND="
distutils_enable_tests pytest
python_test() {
- distutils_install_for_testing
- pytest -vv testing || die "Tests failed under ${EPYTHON}"
+ distutils_install_for_testing --via-root
+ # Skip a broken test
+ # https://github.com/pytest-dev/pytest-xdist/issues/601
+ pytest -vv testing --deselect \
+ testing/acceptance_test.py::TestWarnings::test_warning_captured_deprecated_in_pytest_6 \
+ || die "Tests failed under ${EPYTHON}"
}