summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-05 11:43:28 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-05 11:56:03 +0200
commit7029f2db221a96494c6c16b31ec1624fba148b02 (patch)
tree29b186e6ae847884df67e6f009a5cc147209a3af /dev-python/pytest-repeat
parentx11-misc/xscreensaver: drop old, add 6.08-r1 (diff)
downloadgentoo-7029f2db221a96494c6c16b31ec1624fba148b02.tar.gz
gentoo-7029f2db221a96494c6c16b31ec1624fba148b02.tar.bz2
gentoo-7029f2db221a96494c6c16b31ec1624fba148b02.zip
dev-python/pytest-repeat: New package, v0.9.3
Required for dev-python/simsimd, which is an optional dep for dev-python/elasticsearch. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-repeat')
-rw-r--r--dev-python/pytest-repeat/Manifest1
-rw-r--r--dev-python/pytest-repeat/metadata.xml12
-rw-r--r--dev-python/pytest-repeat/pytest-repeat-0.9.3.ebuild34
3 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/pytest-repeat/Manifest b/dev-python/pytest-repeat/Manifest
new file mode 100644
index 000000000000..87139676046f
--- /dev/null
+++ b/dev-python/pytest-repeat/Manifest
@@ -0,0 +1 @@
+DIST pytest_repeat-0.9.3.tar.gz 6272 BLAKE2B 120f05793d82e6e7bf8c6fc510b218bdc72f453a3548d7a41928f3e228f3438fc3ff49f06025c2061f7f987e66868c653b275b2786b0de1f6eeffc296e4431bd SHA512 7a3fdf0a7403d11549e5cdd95e0f4ee93fd3a59d3f19604477ce73e4e20082f229ec03bd250be52c7d651ccb6aab9e995d2800d6f7931ee144e587741142243b
diff --git a/dev-python/pytest-repeat/metadata.xml b/dev-python/pytest-repeat/metadata.xml
new file mode 100644
index 000000000000..3e13149d0347
--- /dev/null
+++ b/dev-python/pytest-repeat/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">pytest-dev/pytest-repeat</remote-id>
+ <remote-id type="pypi">pytest-repeat</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pytest-repeat/pytest-repeat-0.9.3.ebuild b/dev-python/pytest-repeat/pytest-repeat-0.9.3.ebuild
new file mode 100644
index 000000000000..02419898116d
--- /dev/null
+++ b/dev-python/pytest-repeat/pytest-repeat-0.9.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="pytest plugin for repeating tests"
+HOMEPAGE="
+ https://github.com/pytest-dev/pytest-repeat/
+ https://pypi.org/project/pytest-repeat/
+"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=pytest_repeat
+ epytest
+}