summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-09-19 21:48:07 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-09-19 22:02:07 +0300
commit0118e6d4f01d0c396fb5c64e2de9f082dda2b6de (patch)
tree3efa60be79a0ac1fa7b70fcd9ee9a40f5fcb13d1 /dev-python/pytest-regressions
parentdev-python/astroid: add 2.12.10 (diff)
downloadgentoo-0118e6d4f01d0c396fb5c64e2de9f082dda2b6de.tar.gz
gentoo-0118e6d4f01d0c396fb5c64e2de9f082dda2b6de.tar.bz2
gentoo-0118e6d4f01d0c396fb5c64e2de9f082dda2b6de.zip
dev-python/pytest-regressions: add 2.4.1
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/pytest-regressions')
-rw-r--r--dev-python/pytest-regressions/Manifest1
-rw-r--r--dev-python/pytest-regressions/pytest-regressions-2.4.1.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/pytest-regressions/Manifest b/dev-python/pytest-regressions/Manifest
index a198d56f55c1..93546137fc18 100644
--- a/dev-python/pytest-regressions/Manifest
+++ b/dev-python/pytest-regressions/Manifest
@@ -1 +1,2 @@
DIST pytest-regressions-2.3.1.tar.gz 109616 BLAKE2B cc1c4f5bb221f9b2e53cd235a135a91a301de955fa46a6ab62ebe900878d22ca7814745df72de9a664e16cfc044d99c9048d637dd4f0e3460af25ff2895b6ca8 SHA512 e6c95a085263c9f67223a342a7495e3e46b6c278ad35af726edf7cd0212e516431626d7655250e68f922417d2224568db15992e15f4f4105aada7180372adb64
+DIST pytest-regressions-2.4.1.tar.gz 110863 BLAKE2B 0c2995d475fd194f318a3f1de28942a9711f0a194bec94f863b92fe16af801a6da50a7a7e825af65c581aed1c978c6be7b18252a08841919751f55e83f6633ea SHA512 0f4a0b4735804b4975cd643d0a55262b67f8583e41f292f2b519cc0c99a5c36a6f5abe49a1084fe4e919cb622d90fd21e0374b718a6cd7cfd44b48395dd9ed1a
diff --git a/dev-python/pytest-regressions/pytest-regressions-2.4.1.ebuild b/dev-python/pytest-regressions/pytest-regressions-2.4.1.ebuild
new file mode 100644
index 000000000000..d65e7565e736
--- /dev/null
+++ b/dev-python/pytest-regressions/pytest-regressions-2.4.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Easy to use fixtures to write regression tests"
+HOMEPAGE="https://github.com/ESSS/pytest-regressions"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-datadir[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx doc dev-python/sphinx_rtd_theme
+
+python_test() {
+ local EPYTEST_DESELECT=()
+ local EPYTEST_IGNORE=()
+ if ! has_version "dev-python/matplotlib[${PYTHON_USEDEP}]"; then
+ EPYTEST_DESELECT+=(
+ tests/test_image_regression.py::test_image_regression
+ )
+ fi
+ if ! has_version "dev-python/numpy[${PYTHON_USEDEP}]"; then
+ EPYTEST_IGNORE+=(
+ tests/test_ndarrays_regression.py
+ )
+ fi
+ if ! has_version "dev-python/pandas[${PYTHON_USEDEP}]"; then
+ EPYTEST_DESELECT+=(
+ tests/test_filenames.py::test_foo
+ tests/test_filenames.py::TestClass::test_foo
+ tests/test_filenames.py::TestClassWithIgnoredName::test_foo
+ )
+ EPYTEST_IGNORE+=(
+ tests/test_dataframe_regression.py
+ tests/test_num_regression.py
+ )
+ fi
+ if ! has_version "dev-python/pillow[${PYTHON_USEDEP}]"; then
+ EPYTEST_DESELECT+=(
+ tests/test_image_regression.py
+ )
+ fi
+
+ epytest
+}