summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-12-19 22:13:23 +0100
committerMichał Górny <mgorny@gentoo.org>2021-12-19 22:13:23 +0100
commitdb87acca3e59e7f20e0b63be2189ad4372350a49 (patch)
tree529f9422b7ab7c136b4ad8281e762ccb13d9c8f6 /dev-python/pytest-localserver
parentdev-python/httplib2: Remove old (diff)
downloadgentoo-db87acca3e59e7f20e0b63be2189ad4372350a49.tar.gz
gentoo-db87acca3e59e7f20e0b63be2189ad4372350a49.tar.bz2
gentoo-db87acca3e59e7f20e0b63be2189ad4372350a49.zip
dev-python/pytest-localserver: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-localserver')
-rw-r--r--dev-python/pytest-localserver/Manifest1
-rw-r--r--dev-python/pytest-localserver/files/pytest-localserver-0.5.0-py310-tests.patch39
-rw-r--r--dev-python/pytest-localserver/files/pytest-localserver-0.5.0-setup.patch5
-rw-r--r--dev-python/pytest-localserver/pytest-localserver-0.5.0.ebuild32
4 files changed, 0 insertions, 77 deletions
diff --git a/dev-python/pytest-localserver/Manifest b/dev-python/pytest-localserver/Manifest
index 2f5db7e104b7..475283bcdf74 100644
--- a/dev-python/pytest-localserver/Manifest
+++ b/dev-python/pytest-localserver/Manifest
@@ -1,2 +1 @@
-DIST pytest-localserver-0.5.0.tar.gz 20409 BLAKE2B 62376065ee1aeb698ea5e3bd2d5ea3d6b511cc6793142aad458423513b0e3b358a0d0269a78a0f5aeda44fc53757ff85da786627840ee48cbed8b78ee34c2227 SHA512 aedf1e1c9563396457070df13df228ad0ebdd19173fa2ac5a598288d3e1a1ac8b8a0c0288cba0d8478e43d2e1de4848f2393bf640705916957f12ab31171c6cc
DIST pytest-localserver-0.5.1.tar.gz 19341 BLAKE2B 759a90552b6f950579088a7c41448ad0f000aab980c56361d0e1a40d98a00ee234bf542a6309eb096602536da3fa819b7227a962d0592a801131a019f1617cdc SHA512 dad8b21020cf2f08ad03398b82bad7b47e553a9c6b489b94186bdc61c22f57e7151f8dbeab38ef42d03658104ec42920ec363288a1bdbea34dab6aee1da03c48
diff --git a/dev-python/pytest-localserver/files/pytest-localserver-0.5.0-py310-tests.patch b/dev-python/pytest-localserver/files/pytest-localserver-0.5.0-py310-tests.patch
deleted file mode 100644
index c9a8fbf0f870..000000000000
--- a/dev-python/pytest-localserver/files/pytest-localserver-0.5.0-py310-tests.patch
+++ /dev/null
@@ -1,39 +0,0 @@
---- a/tests/test_https.py 2021-05-24 12:10:07.335676451 -0700
-+++ b/tests/test_https.py 2021-05-24 12:10:23.966572498 -0700
-@@ -11,17 +11,20 @@
- httpsserver = plugin.httpsserver
-
-
-+@pytest.mark.skipif(sys.hexversion >= 0x30a0000, reason="Example certs too weak for py310")
- def test_httpsserver_funcarg(httpsserver):
- assert isinstance(httpsserver, https.SecureContentServer)
- assert httpsserver.is_alive()
- assert httpsserver.server_address
-
-
-+@pytest.mark.skipif(sys.hexversion >= 0x30a0000, reason="Example certs too weak for py310")
- def test_server_does_not_serve_file_at_startup(httpsserver):
- assert httpsserver.code == 204
- assert httpsserver.content == ''
-
-
-+@pytest.mark.skipif(sys.hexversion >= 0x30a0000, reason="Example certs too weak for py310")
- def test_some_content_retrieval(httpsserver):
- httpsserver.serve_content('TEST!')
- resp = requests.get(httpsserver.url, verify=False)
-@@ -29,6 +32,7 @@
- assert resp.status_code == 200
-
-
-+@pytest.mark.skipif(sys.hexversion >= 0x30a0000, reason="Example certs too weak for py310")
- def test_GET_request(httpsserver):
- httpsserver.serve_content('TEST!', headers={'Content-type': 'text/plain'})
- resp = requests.get(httpsserver.url, headers={'User-Agent': 'Test method'}, verify=False)
-@@ -37,6 +41,7 @@
- assert 'text/plain' in resp.headers['Content-type']
-
-
-+@pytest.mark.skipif(sys.hexversion >= 0x30a0000, reason="Example certs too weak for py310")
- def test_HEAD_request(httpsserver):
- httpsserver.serve_content('TEST!', headers={'Content-type': 'text/plain'})
- print(httpsserver.url)
diff --git a/dev-python/pytest-localserver/files/pytest-localserver-0.5.0-setup.patch b/dev-python/pytest-localserver/files/pytest-localserver-0.5.0-setup.patch
deleted file mode 100644
index 1cad7643973a..000000000000
--- a/dev-python/pytest-localserver/files/pytest-localserver-0.5.0-setup.patch
+++ /dev/null
@@ -1,5 +0,0 @@
---- a/setup.cfg 2021-05-24 12:19:38.163108453 -0700
-+++ b/setup.cfg 2021-05-24 12:19:58.714979990 -0700
-@@ -2 +2 @@
--description-file = README
-+description_file = README
diff --git a/dev-python/pytest-localserver/pytest-localserver-0.5.0.ebuild b/dev-python/pytest-localserver/pytest-localserver-0.5.0.ebuild
deleted file mode 100644
index f3bfed9ec65f..000000000000
--- a/dev-python/pytest-localserver/pytest-localserver-0.5.0.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..10} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Py.test plugin to test server connections locally"
-HOMEPAGE="https://pypi.org/project/pytest-localserver/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ppc ppc64 ~riscv sparc x86 ~x64-macos"
-
-RDEPEND=">=dev-python/werkzeug-0.10[${PYTHON_USEDEP}]"
-BDEPEND="
- test? (
- ${RDEPEND}
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- )"
-
-PATCHES=(
- "${FILESDIR}/pytest-localserver-0.5.0-setup.patch"
- "${FILESDIR}/pytest-localserver-0.5.0-py310-tests.patch"
-)
-
-distutils_enable_tests pytest