summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-14 17:28:53 +0100
committerMichał Górny <mgorny@gentoo.org>2020-03-14 17:32:55 +0100
commit56ffc28c749efa412efeca37fca4a6119853c9ff (patch)
tree34c77bf4e1f1a6dc2b38422984c012fb3bc53c88 /dev-python/pytest-localserver
parentdev-python/pytest-timeout: Set DISTUTILS_USE_SETUPTOOLS (diff)
downloadgentoo-56ffc28c749efa412efeca37fca4a6119853c9ff.tar.gz
gentoo-56ffc28c749efa412efeca37fca4a6119853c9ff.tar.bz2
gentoo-56ffc28c749efa412efeca37fca4a6119853c9ff.zip
dev-python/pytest-localserver: Set DISTUTILS_USE_SETUPTOOLS
Closes: https://bugs.gentoo.org/712522 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-localserver')
-rw-r--r--dev-python/pytest-localserver/pytest-localserver-0.5.0.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/dev-python/pytest-localserver/pytest-localserver-0.5.0.ebuild b/dev-python/pytest-localserver/pytest-localserver-0.5.0.ebuild
index 703c4b619ced..ded39fc15de0 100644
--- a/dev-python/pytest-localserver/pytest-localserver-0.5.0.ebuild
+++ b/dev-python/pytest-localserver/pytest-localserver-0.5.0.ebuild
@@ -2,7 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=(python{2_7,3_{6,7,8}} pypy3 )
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python{2_7,3_{6,7,8}} pypy3 )
inherit distutils-r1
@@ -13,10 +15,9 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~sparc ~x86"
-IUSE="test"
RDEPEND=">=dev-python/werkzeug-0.10[${PYTHON_USEDEP}]"
-BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+BDEPEND="
test? (
${RDEPEND}
dev-python/pytest[${PYTHON_USEDEP}]