summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-09-09 04:14:36 +0200
committerMichał Górny <mgorny@gentoo.org>2024-09-09 04:14:36 +0200
commitcf2fd1efe5a0be49427b789dc660f7c89edeedca (patch)
tree7faf1e0f15bf8aa603fd0e335b644c90a376de39 /dev-python/pyscard
parentdev-python/mkdocs-git-revision-date-localized-plugin: Bump to 1.2.8 (diff)
downloadgentoo-cf2fd1efe5a0be49427b789dc660f7c89edeedca.tar.gz
gentoo-cf2fd1efe5a0be49427b789dc660f7c89edeedca.tar.bz2
gentoo-cf2fd1efe5a0be49427b789dc660f7c89edeedca.zip
dev-python/pyscard: Bump to 2.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyscard')
-rw-r--r--dev-python/pyscard/Manifest1
-rw-r--r--dev-python/pyscard/pyscard-2.1.0.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/pyscard/Manifest b/dev-python/pyscard/Manifest
index 1439bcd9e2aa..efbdaf728ac4 100644
--- a/dev-python/pyscard/Manifest
+++ b/dev-python/pyscard/Manifest
@@ -1 +1,2 @@
DIST pyscard-2.0.10.tar.gz 153351 BLAKE2B fb600032321ac0bd372c7aa8fcdd82273af9edcfb51eb5d455296a2a685a291e442209d5c59d60b81cdd8cb3b0699f733e41528fe06ed827558146ba4085c97d SHA512 231d5abc0ad31ae7f0e394f928045346323f1040b313394a3d235282feb79bfec0d124ebde84017178dfa1983beadfb245a33bfa6a75b4fab9e65c3090b9e9cb
+DIST pyscard-2.1.0.tar.gz 153511 BLAKE2B 072fb49ab17bdb32cf3381b9e769125b1c934f5830af6e33547a083025019c01cf61e077a1b4c5883572aa6db1e006f4a320fe07e097e6687dca45996aa1c6a2 SHA512 de0c26108751cc2b674968982f7982ad971c93890c32a0731394074dabe72805399755ed9f042aa4bc019e95b705d4394e0ac844699bbf8192ab5e779e43f2fe
diff --git a/dev-python/pyscard/pyscard-2.1.0.ebuild b/dev-python/pyscard/pyscard-2.1.0.ebuild
new file mode 100644
index 000000000000..2efc6e371faa
--- /dev/null
+++ b/dev-python/pyscard/pyscard-2.1.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Smart card support in python"
+HOMEPAGE="
+ https://pyscard.sourceforge.io/
+ https://github.com/LudovicRousseau/pyscard/
+ https://pypi.org/project/pyscard/
+"
+SRC_URI="
+ https://downloads.sourceforge.net/project/pyscard/pyscard/pyscard%20${PV}/${P}.tar.gz
+"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+DEPEND="
+ sys-apps/pcsc-lite
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-lang/swig
+"
+
+distutils_enable_tests unittest
+
+pkg_postinst() {
+ optfeature "Gui support" dev-python/wxpython
+ optfeature "Support of remote readers with Pyro" dev-python/Pyro4
+}
+
+python_test() {
+ cd test || die
+ eunittest
+}