summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-09-29 16:43:25 +0200
committerMichał Górny <mgorny@gentoo.org>2024-09-29 17:20:07 +0200
commita2cbc231507459a84c4a1815f7e558463b542b2c (patch)
treeda71a929a2c70acf03c0db4cfde294b17aebfc9d /dev-python/pyparsing
parentdev-python/mkdocs-material: Bump to 9.5.39 (diff)
downloadgentoo-a2cbc231507459a84c4a1815f7e558463b542b2c.tar.gz
gentoo-a2cbc231507459a84c4a1815f7e558463b542b2c.tar.bz2
gentoo-a2cbc231507459a84c4a1815f7e558463b542b2c.zip
dev-python/pyparsing: Bump to 3.2.0_beta3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyparsing')
-rw-r--r--dev-python/pyparsing/Manifest1
-rw-r--r--dev-python/pyparsing/pyparsing-3.2.0_beta3.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/pyparsing/Manifest b/dev-python/pyparsing/Manifest
index 80526b73e638..511c31e43086 100644
--- a/dev-python/pyparsing/Manifest
+++ b/dev-python/pyparsing/Manifest
@@ -1,2 +1,3 @@
DIST pyparsing-3.1.4.tar.gz 900231 BLAKE2B 121092316528a69f79a8fac5e903de513c4193bd00d5ef7e98dfcb09f3a48eb3384217ede39b0f954f58bdade8644931ce8cef41729539fc1be3dfb910b90be7 SHA512 b475e5571510cd7b07fecbc8ae583b1e75a6308b64018d2884570dfa461e0529b96d02d11403cecac41f92b5d802a5dd4bbf9f8321d58ffa2d24cb89b86652e1
DIST pyparsing-3.2.0b2.tar.gz 913100 BLAKE2B 50cb171b9fec23d04ea30b649f98dba605c317ea50a07a94f4391a63fac9f177421a910b3d52010238692ebae4dce0d236f9f32676db1402514dc5d873a4fae1 SHA512 401d80d7ffffb5407d26a80d1638c0c9516bf242d8b3ac0d0947914105a6b42cce355cc52002921103aee7b668042179be43ea3929b2cda9cf21da99aa0f971e
+DIST pyparsing-3.2.0b3.tar.gz 914295 BLAKE2B d542366991972641d5bda7b2d7c1df7de9239d4f8cfdae5ce68d6e763cbc8d5fe87d0bfea18d2b13a6b53d15fa1e97f0d0a9f73735fcb7599f1514f4e1c0e4a6 SHA512 8d743d79f5b099330c186a8a5671d284254db314648ce4f59ce28795122561489d1015419a8ad14dae46d62d1c0c7ffd72b366320ea1e84d4a13655bc8d62e95
diff --git a/dev-python/pyparsing/pyparsing-3.2.0_beta3.ebuild b/dev-python/pyparsing/pyparsing-3.2.0_beta3.ebuild
new file mode 100644
index 000000000000..bd3fdd7b49b7
--- /dev/null
+++ b/dev-python/pyparsing/pyparsing-3.2.0_beta3.ebuild
@@ -0,0 +1,58 @@
+# Copyright 2004-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 8 -- sys-apps/portage dep
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Easy-to-use Python module for text parsing"
+HOMEPAGE="
+ https://github.com/pyparsing/pyparsing/
+ https://pypi.org/project/pyparsing/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="examples"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # railroad-diagrams not packaged (and not suitable for packaging yet)
+ tests/test_diagram.py
+ )
+ local EPYTEST_DESELECT=(
+ # also railroad-diagrams
+ tests/test_examples.py::TestExamples::test_range_check
+ tests/test_examples.py::TestExamples::test_rosettacode
+ tests/test_unit.py::Test02_WithoutPackrat::testEmptyExpressionsAreHandledProperly
+ tests/test_unit.py::Test04_WithPackrat::testEmptyExpressionsAreHandledProperly
+ tests/test_unit.py::Test06_WithBoundedPackrat::testEmptyExpressionsAreHandledProperly
+ tests/test_unit.py::Test08_WithUnboundedPackrat::testEmptyExpressionsAreHandledProperly
+ tests/test_unit.py::Test09_WithLeftRecursionParsing::testEmptyExpressionsAreHandledProperly
+ tests/test_unit.py::Test10_WithLeftRecursionParsingBoundedMemo::testEmptyExpressionsAreHandledProperly
+ )
+
+ if ! has_version "dev-python/matplotlib[${PYTHON_USEDEP}]"; then
+ EPYTEST_IGNORE+=(
+ tests/test_matplotlib_cases.py
+ )
+ fi
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}
+
+python_install_all() {
+ if use examples; then
+ docompress -x /usr/share/doc/${PF}/examples
+ dodoc -r examples
+ fi
+ distutils-r1_python_install_all
+}