summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-23 04:00:13 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-23 04:11:30 +0200
commit303fdc876d93eb3ac13cffdd17775506b1d127a5 (patch)
tree79dc5088a3eb23f799a0386fc2b276eed214d401 /dev-python/pylast
parentdev-python/google-api-python-client: Bump to 2.130.0 (diff)
downloadgentoo-303fdc876d93eb3ac13cffdd17775506b1d127a5.tar.gz
gentoo-303fdc876d93eb3ac13cffdd17775506b1d127a5.tar.bz2
gentoo-303fdc876d93eb3ac13cffdd17775506b1d127a5.zip
dev-python/pylast: Bump to 5.3.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pylast')
-rw-r--r--dev-python/pylast/Manifest1
-rw-r--r--dev-python/pylast/pylast-5.3.0.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/pylast/Manifest b/dev-python/pylast/Manifest
index d87f4abd85e2..7db41c679c5a 100644
--- a/dev-python/pylast/Manifest
+++ b/dev-python/pylast/Manifest
@@ -1 +1,2 @@
DIST pylast-5.2.0.tar.gz 41137 BLAKE2B a7742bd2a23e281ab1a12d0198c74f1b5d8302700cb58490a5b3bff693098c8c3bf548ed52ca7f8cefecbcc10972c57da9ca04fe1d791141aacbb84ead9592ed SHA512 1ae76ff4ec6f009388abfcf8525f1c19e47cbabaace1f5e8c518819d0856168d855b789e3c08a9699dd7ab88ebfc7c3ab81c2d74a0fa1fd210450741b99da8c6
+DIST pylast-5.3.0.tar.gz 41552 BLAKE2B 0d6fd60e02f6106cbbfe2027614d8d403c54ee1f749ea697dba7d863e7a1fc647f95d2ea341e1d0ecfa2900a1ae117920466bb8f8a0728c5a9dea6be8d1009f0 SHA512 b8d015d9d1452a650a6fc05019a145c2c5104c1acd0e296d7a9b536fd91710b4efe3dab2646b4b373ca13278fbdc385a64472829dfd1cf8980a22a5f2314afe9
diff --git a/dev-python/pylast/pylast-5.3.0.ebuild b/dev-python/pylast/pylast-5.3.0.ebuild
new file mode 100644
index 000000000000..d4308e6d07b6
--- /dev/null
+++ b/dev-python/pylast/pylast-5.3.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python interface to last.fm and other api-compatible websites"
+HOMEPAGE="
+ https://pypi.org/project/pylast/
+ https://github.com/pylast/pylast/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/httpx[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ dev-python/flaky[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest