summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-07-19 20:43:46 +0200
committerMichał Górny <mgorny@gentoo.org>2018-07-19 20:59:04 +0200
commit8ad5c2faff1144be19acb75090588fb4d8ad70b7 (patch)
tree7b80ac84fc4e0e9cfd20b5731afbf567dee30ba3 /dev-python/pygobject
parentdev-python/pycairo: Enable py3.7 (diff)
downloadgentoo-8ad5c2faff1144be19acb75090588fb4d8ad70b7.tar.gz
gentoo-8ad5c2faff1144be19acb75090588fb4d8ad70b7.tar.bz2
gentoo-8ad5c2faff1144be19acb75090588fb4d8ad70b7.zip
dev-python/pygobject: Improve src_test
Spawn virtx once for all tests. Use local variables.
Diffstat (limited to 'dev-python/pygobject')
-rw-r--r--dev-python/pygobject/pygobject-3.24.1.ebuild14
1 files changed, 6 insertions, 8 deletions
diff --git a/dev-python/pygobject/pygobject-3.24.1.ebuild b/dev-python/pygobject/pygobject-3.24.1.ebuild
index 0eae8c8d7504..1013f9e4392f 100644
--- a/dev-python/pygobject/pygobject-3.24.1.ebuild
+++ b/dev-python/pygobject/pygobject-3.24.1.ebuild
@@ -90,17 +90,15 @@ src_compile() {
}
src_test() {
- export GIO_USE_VFS="local" # prevents odd issues with deleting ${T}/.gvfs
- export GIO_USE_VOLUME_MONITOR="unix" # prevent udisks-related failures in chroots, bug #449484
- export SKIP_PEP8="yes"
+ local -x GIO_USE_VFS="local" # prevents odd issues with deleting ${T}/.gvfs
+ local -x GIO_USE_VOLUME_MONITOR="unix" # prevent udisks-related failures in chroots, bug #449484
+ local -x SKIP_PEP8="yes"
testing() {
- export XDG_CACHE_HOME="${T}/${EPYTHON}"
- run_in_build_dir virtx emake check
- unset XDG_CACHE_HOME
+ local -x XDG_CACHE_HOME="${T}/${EPYTHON}"
+ emake -C "${BUILD_DIR}" check
}
- python_foreach_impl testing
- unset GIO_USE_VFS
+ virtx python_foreach_impl testing
}
src_install() {