summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2020-01-26 13:35:55 -0800
committerZac Medico <zmedico@gentoo.org>2020-01-26 13:41:39 -0800
commite935d8827c763862f80081b8d7f20c14cb799ae4 (patch)
tree822fc2082fb468b2fe186f197f121114b7f2f960 /dev-python/pyghmi/pyghmi-1.5.5.ebuild
parentdev-python/djangorestframework: 3.10.3 bump (diff)
downloadgentoo-e935d8827c763862f80081b8d7f20c14cb799ae4.tar.gz
gentoo-e935d8827c763862f80081b8d7f20c14cb799ae4.tar.bz2
gentoo-e935d8827c763862f80081b8d7f20c14cb799ae4.zip
dev-python/pyghmi: Bump to version 1.5.5
Package-Manager: Portage-2.3.85, Repoman-2.3.20 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'dev-python/pyghmi/pyghmi-1.5.5.ebuild')
-rw-r--r--dev-python/pyghmi/pyghmi-1.5.5.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/pyghmi/pyghmi-1.5.5.ebuild b/dev-python/pyghmi/pyghmi-1.5.5.ebuild
new file mode 100644
index 000000000000..a2085f3c7d12
--- /dev/null
+++ b/dev-python/pyghmi/pyghmi-1.5.5.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="A pure python implementation of IPMI protocol"
+HOMEPAGE="https://github.com/openstack/pyghmi/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=">=dev-python/cryptography-2.1[${PYTHON_USEDEP}]
+ dev-python/pbr[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.8.1[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/stestr-1.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.6.5[${PYTHON_USEDEP}]
+ >=dev-python/subunit-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ stestr run || die "Tests failed under ${EPYTHON}"
+}