summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-09-20 10:47:28 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-10-06 12:26:30 +0300
commitc89ce57ac435838ca0e600c4a0c32fe5a9facc67 (patch)
treec9dbe0db27660265668fc4600043f988df88ac7a /dev-python/pydata-sphinx-theme
parentnet-misc/openssh-8.4_p1-r1: fix removal of /var/empty for Prefix (diff)
downloadgentoo-c89ce57ac435838ca0e600c4a0c32fe5a9facc67.tar.gz
gentoo-c89ce57ac435838ca0e600c4a0c32fe5a9facc67.tar.bz2
gentoo-c89ce57ac435838ca0e600c4a0c32fe5a9facc67.zip
dev-python/pydata-sphinx-theme: bug fix in test phase
Closes: https://bugs.gentoo.org/743694 Package-Manager: Portage-3.0.7, Repoman-3.0.1 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net> Closes: https://github.com/gentoo/gentoo/pull/17608 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-python/pydata-sphinx-theme')
-rw-r--r--dev-python/pydata-sphinx-theme/pydata-sphinx-theme-0.4.0.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-python/pydata-sphinx-theme/pydata-sphinx-theme-0.4.0.ebuild b/dev-python/pydata-sphinx-theme/pydata-sphinx-theme-0.4.0.ebuild
index cdb917978f59..6a119e929da9 100644
--- a/dev-python/pydata-sphinx-theme/pydata-sphinx-theme-0.4.0.ebuild
+++ b/dev-python/pydata-sphinx-theme/pydata-sphinx-theme-0.4.0.ebuild
@@ -4,7 +4,6 @@
EAPI=7
PYTHON_COMPAT=( python3_{7,8} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1
@@ -26,3 +25,8 @@ RDEPEND="dev-python/sphinx[${PYTHON_USEDEP}]"
# ModuleNotFoundError: No module named 'plotly' even if dev-python/plotly is installed
#distutils_enable_sphinx docs dev-python/commonmark dev-python/recommonmark dev-python/numpydoc dev-python/jupyter-sphinx dev-python/plotly
distutils_enable_tests pytest
+
+python_test() {
+ PYTHONPATH="${S}"
+ pytest -vv || die "Tests failed with ${EPYTHON}"
+}