summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2025-01-05 03:30:40 +0100
committerMichał Górny <mgorny@gentoo.org>2025-01-05 03:30:40 +0100
commit9123d878a2274ef1269ce139678c067906c4f4df (patch)
tree92065de963b140ece5955cd62d1448f97c048d2b /dev-python/pydantic
parentdev-python/jellyfish: Remove old (diff)
downloadgentoo-9123d878a2274ef1269ce139678c067906c4f4df.tar.gz
gentoo-9123d878a2274ef1269ce139678c067906c4f4df.tar.bz2
gentoo-9123d878a2274ef1269ce139678c067906c4f4df.zip
dev-python/pydantic: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pydantic')
-rw-r--r--dev-python/pydantic/Manifest1
-rw-r--r--dev-python/pydantic/pydantic-2.10.3.ebuild65
2 files changed, 0 insertions, 66 deletions
diff --git a/dev-python/pydantic/Manifest b/dev-python/pydantic/Manifest
index 6b7f67ea5352..bde876b67459 100644
--- a/dev-python/pydantic/Manifest
+++ b/dev-python/pydantic/Manifest
@@ -1,3 +1,2 @@
-DIST pydantic-2.10.3.tar.gz 786486 BLAKE2B 74abce2fb92704ab15b4b855fb1d96256720cca086a9911a031a5ffcf3c0fc8fcc2c9975affca8796709a13b4c5173c9598ec939207aa544762767577dc7117f SHA512 d5264c29b042ce24e8c03bad7a7db1fa556fb84c90b287cb87ddc52560d60db3d363ed7f05ea1af9e1469e52150388c9b119982cea5272960c0db2b31bd57fc6
DIST pydantic-2.10.4.tar.gz 762094 BLAKE2B 0d9f3534df4ae05b2724788944776d0ac95329cfe48d59627e71b4769c7813410d0c64f0d7ca96e28aec8e403b2507873673b87acb230bb12ad5d4f304eb76ca SHA512 1c7bfcc214195d8db0cadbdb177da3e2e3ea596d695360036b0a268410711a780f9a88df622016d9bb6d39596f20e01bebc4cf38bdbe5dc987cb80fbb14aeb56
DIST pydantic-2.9.2.tar.gz 769917 BLAKE2B 4e34fda6a9e8e8331278d0b7d0c2dfd61bde637c126fa6dabf78a09c6ef993f84dc8df6af421c8fb6d69c8e1c387a40e4bcd38cbe02f5ac521c6c70821735763 SHA512 2aace9e79a98bd94e5dc626736a245051912a11fdce36013d2ad2f96b266052386a3e12b259dca30ddc38b63c6b00b5bcc9cd5e80f7805de4d8701064f0982aa
diff --git a/dev-python/pydantic/pydantic-2.10.3.ebuild b/dev-python/pydantic/pydantic-2.10.3.ebuild
deleted file mode 100644
index fd3e9408f99c..000000000000
--- a/dev-python/pydantic/pydantic-2.10.3.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=hatchling
-PYTHON_COMPAT=( pypy3 python3_{10..13} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Data parsing and validation using Python type hints"
-HOMEPAGE="
- https://github.com/pydantic/pydantic/
- https://pypi.org/project/pydantic/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
-
-RDEPEND="
- >=dev-python/annotated-types-0.6.0[${PYTHON_USEDEP}]
- ~dev-python/pydantic-core-2.27.1[${PYTHON_USEDEP}]
- >=dev-python/typing-extensions-4.12.2[${PYTHON_USEDEP}]
- dev-python/tzdata[${PYTHON_USEDEP}]
-"
-BDEPEND="
- >=dev-python/hatch-fancy-pypi-readme-22.5.0[${PYTHON_USEDEP}]
- test? (
- dev-python/cloudpickle[${PYTHON_USEDEP}]
- dev-python/dirty-equals[${PYTHON_USEDEP}]
- >=dev-python/email-validator-2.0.0[${PYTHON_USEDEP}]
- >=dev-python/faker-18.13.0[${PYTHON_USEDEP}]
- >=dev-python/jsonschema-4.23.0[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]
- dev-python/rich[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- sed -i -e '/benchmark/d' pyproject.toml || die
- distutils-r1_src_prepare
-}
-
-python_test() {
- local EPYTEST_DESELECT=()
- local EPYTEST_IGNORE=(
- # require pytest-examples
- tests/test_docs.py
- # benchmarks
- tests/benchmarks
- )
-
- if ! has_version "dev-python/cloudpickle[${PYTHON_USEDEP}]"; then
- EPYTEST_IGNORE+=(
- tests/test_pickle.py
- )
- fi
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest -p pytest_mock
-}