summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-05 08:31:57 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-05 09:57:45 +0200
commit0428f2f046cb83b216277df7e9f7a4cbe53d1a6c (patch)
tree2867dab151a74e350c075fc3d5fe1b64d4c1ccd7 /dev-python/pydantic
parentx11-plugins/wmmp: version bump (v0.12.6) (diff)
downloadgentoo-0428f2f046cb83b216277df7e9f7a4cbe53d1a6c.tar.gz
gentoo-0428f2f046cb83b216277df7e9f7a4cbe53d1a6c.tar.bz2
gentoo-0428f2f046cb83b216277df7e9f7a4cbe53d1a6c.zip
dev-python/pydantic: Bump to 1.10.11
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pydantic')
-rw-r--r--dev-python/pydantic/Manifest1
-rw-r--r--dev-python/pydantic/pydantic-1.10.11.ebuild91
2 files changed, 92 insertions, 0 deletions
diff --git a/dev-python/pydantic/Manifest b/dev-python/pydantic/Manifest
index 3d7b80e8fb72..48a0b3ae6a90 100644
--- a/dev-python/pydantic/Manifest
+++ b/dev-python/pydantic/Manifest
@@ -1,3 +1,4 @@
+DIST pydantic-1.10.11.gh.tar.gz 766203 BLAKE2B 5ab426a805a471baac409c82d5a0cdaa9eae0bc46c0c0643ab653db68ccd5bd6db2c2e6aa12113f513e35d590b291986d463e776515f495991e9818541ab2553 SHA512 494e692781dd8fe3980e06ba975fa0c86ad32e36bffead8c836e1680ff3c43de458ef5a344182950060fc3616208d82ad77fd9098811384208f25a9b72c0fe42
DIST pydantic-1.10.9.gh.tar.gz 765868 BLAKE2B 802c542d75b41ff2926215bf4f6bd68a906d581db7b08ed85577f9021d259717f3ef8dbacfe381723aa042aab8720ad182c57fee188f2436b33d21164e24ba23 SHA512 d376a302eac3427cdc8da0ed2fab01c0b5e7a059447777a53c394a60dac5fa0066488be8553022bb5aa89367d5a2e80e5d6e3cb39d9272843718dd07f6acd11e
DIST pydantic-2.0.tar.gz 572748 BLAKE2B 611bb31065c1016d18137c0b5bfb0c7730243f727c1ffa3e3264f78fe750f31832d7388c177f59e0a676fa1eca7fc102e425fef59f97dc852c17b400723efc63 SHA512 830f5379f623e128f23f6d0672f0005a8b184b646e162be67fc08008f75dff53012c1576f0530ef9f6723ac664cfd662432de8f35cbcf98963ed8a680d697ce9
DIST pydantic-2.0b3.tar.gz 543489 BLAKE2B 89faa3ca4187840ad2fa8025bfef8fba265eaf88e31a75751aa619e1235af08e33aa3b7a713da9e69119a43316da893b02e669d3e704781f77fe94598db40410 SHA512 db6690d15f91b635f0a4002f81cb9ba15e625ece4172bd355e5aef7058f6f385d0b3d1f7e2cab3e25aa6a5f48f6455965a1adaa18fc5a2ca5845c09804c9a3dd
diff --git a/dev-python/pydantic/pydantic-1.10.11.ebuild b/dev-python/pydantic/pydantic-1.10.11.ebuild
new file mode 100644
index 000000000000..742af7f9f99e
--- /dev/null
+++ b/dev-python/pydantic/pydantic-1.10.11.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P=${P/_beta/b}
+DESCRIPTION="Data parsing and validation using Python type hints"
+HOMEPAGE="
+ https://github.com/pydantic/pydantic/
+ https://pypi.org/project/pydantic/
+"
+SRC_URI="
+ https://github.com/pydantic/pydantic/archive/v${PV/_beta/b}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="native-extensions"
+
+RDEPEND="
+ >=dev-python/typing-extensions-4.1.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ native-extensions? (
+ <dev-python/cython-3[${PYTHON_USEDEP}]
+ )
+ test? (
+ >=dev-python/email-validator-1.2.1[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/python-dotenv[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e '/CFLAGS/d' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_compile() {
+ if [[ ${EPYTHON} == pypy3 ]] || ! use native-extensions; then
+ # do not build extensions on PyPy to workaround
+ # https://github.com/cython/cython/issues/4763
+ local -x SKIP_CYTHON=1
+ fi
+ distutils-r1_python_compile
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=pytest_mock
+
+ local EPYTEST_DESELECT=(
+ # flaky test, known upstream
+ tests/test_hypothesis_plugin.py::test_can_construct_models_with_all_fields
+ # mypy linting causes regressions with new mypy versions
+ tests/mypy
+ )
+ case ${EPYTHON} in
+ pypy3)
+ EPYTEST_DESELECT+=(
+ tests/test_private_attributes.py::test_private_attribute
+ tests/test_private_attributes.py::test_private_attribute_annotation
+ tests/test_private_attributes.py::test_private_attribute_factory
+ tests/test_private_attributes.py::test_private_attribute_multiple_inheritance
+ tests/test_private_attributes.py::test_underscore_attrs_are_private
+ )
+ ;;
+ python3.12)
+ EPYTEST_DESELECT+=(
+ tests/test_abc.py::test_model_subclassing_abstract_base_classes_without_implementation_raises_exception
+ tests/test_generics.py::test_partial_specification_name
+ tests/test_generics.py::test_parse_generic_json
+ tests/test_types.py::test_secretfield
+ )
+ ;;
+ esac
+ rm -rf pydantic || die
+ epytest
+}