summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2022-11-29 00:12:10 +0100
committerSebastian Pipping <sping@gentoo.org>2022-11-29 01:42:37 +0100
commit4a46118edd3a0616443a3ed026125c6b0462c572 (patch)
tree347f2876262be2960050c122b489ea68488cfc5d /dev-python/pycxx
parentdev-vcs/svneverever: Drop old (diff)
downloadgentoo-4a46118edd3a0616443a3ed026125c6b0462c572.tar.gz
gentoo-4a46118edd3a0616443a3ed026125c6b0462c572.tar.bz2
gentoo-4a46118edd3a0616443a3ed026125c6b0462c572.zip
dev-python/pycxx: 7.1.7 + Python 3.11 + fix false remote ID
Signed-off-by: Sebastian Pipping <sping@gentoo.org>
Diffstat (limited to 'dev-python/pycxx')
-rw-r--r--dev-python/pycxx/Manifest1
-rw-r--r--dev-python/pycxx/metadata.xml3
-rw-r--r--dev-python/pycxx/pycxx-7.1.7.ebuild37
3 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/pycxx/Manifest b/dev-python/pycxx/Manifest
index bd8fdd9c4a29..b2a1ef174f08 100644
--- a/dev-python/pycxx/Manifest
+++ b/dev-python/pycxx/Manifest
@@ -1 +1,2 @@
DIST pycxx-7.1.5.tar.gz 156343 BLAKE2B 099de7f88c19ec86aea67b503e6fbdc0df66bbdd3bdc0ff7f8ce77425be9486e6abebed8548f9ac764688a85e62cda77d3832f460e5678b4c07b1c6d2123b257 SHA512 0f980298739886d0c05ddd5ee23ebb234014b8276d811e62dc5b0a738666c6a011ad3f4aeeb7b1b404d8bff87dddfc30f68eec9c6bd13d5f262a2f7c53e273be
+DIST pycxx-7.1.7.tar.gz 156383 BLAKE2B 69a454615c9a7cdc57f4c357b9e3805821711bc48efb82e684da6066069ff0ee6af3b76911a705adb6f984969659441d331a8470061b514180ddf53f6494a33d SHA512 5439b2f72a7f04a628e7e93d093566654f3b4eafe78a7834005f86fb08e614f22f4d1fffb8d626e46cd56880ff7792e494ee3282b313ce668a7497d2bc1fbea9
diff --git a/dev-python/pycxx/metadata.xml b/dev-python/pycxx/metadata.xml
index 0de8867fa9b6..898c29b01984 100644
--- a/dev-python/pycxx/metadata.xml
+++ b/dev-python/pycxx/metadata.xml
@@ -11,6 +11,9 @@
</longdescription>
<upstream>
<remote-id type="sourceforge">cxx</remote-id>
+ <!--
+ Note, PyCXX is not on PyPI, this is a *different* project:
<remote-id type="pypi">pycxx</remote-id>
+ -->
</upstream>
</pkgmetadata>
diff --git a/dev-python/pycxx/pycxx-7.1.7.ebuild b/dev-python/pycxx/pycxx-7.1.7.ebuild
new file mode 100644
index 000000000000..49ffda406c9a
--- /dev/null
+++ b/dev-python/pycxx/pycxx-7.1.7.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+PYTHON_COMPAT=( python3_{8..11} )
+# DISTUTILS_USE_PEP517=setuptools broken, installs files to /usr/CXX
+DISTUTILS_USE_SETUPTOOLS=no
+
+inherit distutils-r1
+
+DESCRIPTION="Set of facilities to extend Python with C++"
+HOMEPAGE="http://cxx.sourceforge.net"
+SRC_URI="mirror://sourceforge/cxx/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+IUSE="doc examples"
+
+python_prepare_all() {
+ # Without this, pysvn fails.
+ # Src/Python3/cxxextensions.c: No such file or directory
+ sed -e "/^#include/s:Src/::" -i Src/*.{c,cxx} || die "sed failed"
+
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( Doc/. )
+ if use examples ; then
+ docinto examples
+ dodoc -r Demo/Python{2,3}/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ distutils-r1_python_install_all
+}