summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-10-19 07:36:35 +0200
committerMichał Górny <mgorny@gentoo.org>2024-10-19 08:03:49 +0200
commit305e72e2ea644da82f1dd1b2c997f2fc42e8af0b (patch)
tree5ed8f91fbea12618b95c644fd2578a583d6af8c6 /dev-python/pudb
parentdev-python/pudb: Remove old (diff)
downloadgentoo-305e72e2ea644da82f1dd1b2c997f2fc42e8af0b.tar.gz
gentoo-305e72e2ea644da82f1dd1b2c997f2fc42e8af0b.tar.bz2
gentoo-305e72e2ea644da82f1dd1b2c997f2fc42e8af0b.zip
dev-python/pudb: Bump to 2024.1.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pudb')
-rw-r--r--dev-python/pudb/Manifest1
-rw-r--r--dev-python/pudb/pudb-2024.1.3.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/pudb/Manifest b/dev-python/pudb/Manifest
index 9a1fa8ad53ec..526cc71c6874 100644
--- a/dev-python/pudb/Manifest
+++ b/dev-python/pudb/Manifest
@@ -1 +1,2 @@
DIST pudb-2024.1.2.tar.gz 226551 BLAKE2B b89db9a56f933474cddd332a71216c73631324efc0b046044133e912bc9783c3e89d9a67e539fdc9703fd728a308a33687587c7b63427b7ca824cd425013b434 SHA512 0db7af15227c9bddd91aa685e90cef5c071f930399731681da651293a71732b2bc9e2afbd7cc5080ad51e7c54980b93afc8b8f53b054737b7a76270bf3414206
+DIST pudb-2024.1.3.tar.gz 219443 BLAKE2B edfc2b8799cefc8f81eaac37e07a90b42870b6a3a6ddcc0e7aee785ea6f720fa0db0dc7b9dda6508a9a9e9718812bdf1d6729a12c2d6974f2531022dea2dd153 SHA512 da3702a1debeeae7b48012e1241be9d85f3e12714e7d37771863d8d26dabb9615c75bff9a0285647327852d9814eb3ddbc15fcb736d8f4a3f6030d71a12fd258
diff --git a/dev-python/pudb/pudb-2024.1.3.ebuild b/dev-python/pudb/pudb-2024.1.3.ebuild
new file mode 100644
index 000000000000..5edccb39bc66
--- /dev/null
+++ b/dev-python/pudb/pudb-2024.1.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi optfeature
+
+DESCRIPTION="A full-screen, console-based Python debugger"
+HOMEPAGE="
+ https://documen.tician.de/pudb/
+ https://github.com/inducer/pudb/
+ https://pypi.org/project/pudb/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/jedi-0.18[${PYTHON_USEDEP}]
+ >=dev-python/packaging-20.0[${PYTHON_USEDEP}]
+ >=dev-python/pygments-2.7.4[${PYTHON_USEDEP}]
+ >=dev-python/urwid-2.4[${PYTHON_USEDEP}]
+ dev-python/urwid-readline[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature_header "Install the following packages for additional functionality:"
+ optfeature "Auto-complete support" dev-python/jedi
+}