summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2019-11-22 10:25:41 -0800
committerPatrick McLean <chutzpah@gentoo.org>2019-11-22 10:26:01 -0800
commit5640da992e3c6689bb36cd0cc9a0115e89b6c996 (patch)
tree9b14d533553d34a8d4d15fe0b25e4081d8f9c2ed /dev-python/psutil
parentsys-apps/yarn: Bump to version 1.19.2 (diff)
downloadgentoo-5640da992e3c6689bb36cd0cc9a0115e89b6c996.tar.gz
gentoo-5640da992e3c6689bb36cd0cc9a0115e89b6c996.tar.bz2
gentoo-5640da992e3c6689bb36cd0cc9a0115e89b6c996.zip
dev-python/psutil-5.6.5: Fix tests if already installed
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/psutil')
-rw-r--r--dev-python/psutil/psutil-5.6.5.ebuild5
1 files changed, 2 insertions, 3 deletions
diff --git a/dev-python/psutil/psutil-5.6.5.ebuild b/dev-python/psutil/psutil-5.6.5.ebuild
index ee3896643a57..ef2b398012ec 100644
--- a/dev-python/psutil/psutil-5.6.5.ebuild
+++ b/dev-python/psutil/psutil-5.6.5.ebuild
@@ -23,8 +23,6 @@ DEPEND="
)
"
-# Many tests fail, even on a regular tox run on a upstream clone
-#RESTRICT="test"
RESTRICT="!test? ( test )"
PATCHES=(
@@ -36,8 +34,9 @@ python_test() {
ewarn "Not running tests on ${EPYTHON} since they are broken"
return 0
fi
+
# since we are running in an environment a bit similar to CI,
# let's skip the tests that are disable for CI
- TRAVIS=1 APPVEYOR=1 ${PYTHON} psutil/tests/__main__.py || \
+ TRAVIS=1 APPVEYOR=1 PYTHONPATH="${BUILD_DIR}/lib" ${PYTHON} psutil/tests/__main__.py || \
die "tests failed with ${EPYTHON}"
}