summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Zander <negril.nx+gentoo@gmail.com>2024-07-07 22:01:48 +0200
committerSam James <sam@gentoo.org>2024-07-09 13:51:25 +0100
commitea43d63d1245912a9bf8e259b70f3e2cdf51d204 (patch)
tree06a6790cea76d66cf8992f6506ee241b3633285a /dev-python/protobuf-python
parentdev-python/protobuf-python: add 5.27.2 (diff)
downloadgentoo-ea43d63d1245912a9bf8e259b70f3e2cdf51d204.tar.gz
gentoo-ea43d63d1245912a9bf8e259b70f3e2cdf51d204.tar.bz2
gentoo-ea43d63d1245912a9bf8e259b70f3e2cdf51d204.zip
dev-python/protobuf-python: update 5.27.2, drop 9999
protobuf-python can no longer be build from github archives. https://github.com/protocolbuffers/protobuf/blob/main/python/README.md#building-from-setuppy Closes: https://bugs.gentoo.org/920646 Closes: https://bugs.gentoo.org/933068 Closes: https://bugs.gentoo.org/927521 Closes: https://github.com/gentoo/gentoo/pull/36885 Signed-off-by: Paul Zander <negril.nx+gentoo@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/protobuf-python')
-rw-r--r--dev-python/protobuf-python/protobuf-python-5.27.2.ebuild74
-rw-r--r--dev-python/protobuf-python/protobuf-python-9999.ebuild79
2 files changed, 13 insertions, 140 deletions
diff --git a/dev-python/protobuf-python/protobuf-python-5.27.2.ebuild b/dev-python/protobuf-python/protobuf-python-5.27.2.ebuild
index 8f12c5727960..b0d4a3ec76a7 100644
--- a/dev-python/protobuf-python/protobuf-python-5.27.2.ebuild
+++ b/dev-python/protobuf-python/protobuf-python-5.27.2.ebuild
@@ -3,76 +3,28 @@
EAPI=8
+# Default implementation currently is upb, which doesn't match dev-libs/protobuf
+# https://github.com/protocolbuffers/protobuf/blob/main/python/README.md#implementation-backends
+
DISTUTILS_EXT=1
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{10..13} )
+PYPI_PN="protobuf"
-inherit distutils-r1
-
-PARENT_PN="${PN/-python/}"
-PARENT_PV="$(ver_cut 2-)"
-
-[[ "${PV}" == *9999 ]] && PARENT_PV="28.0"
-
-PARENT_P="${PARENT_PN}-${PARENT_PV}"
+inherit distutils-r1 pypi
DESCRIPTION="Google's Protocol Buffers - Python bindings"
HOMEPAGE="
- https://developers.google.com/protocol-buffers/
+ https://protobuf.dev/
https://pypi.org/project/protobuf/
"
-if [[ "${PV}" == *9999 ]]; then
- inherit git-r3
-
- EGIT_REPO_URI="https://github.com/protocolbuffers/protobuf.git"
- EGIT_SUBMODULES=()
- EGIT_CHECKOUT_DIR="${WORKDIR}/${PARENT_P}"
-else
- SRC_URI="
- https://github.com/protocolbuffers/protobuf/archive/v${PARENT_PV}.tar.gz
- -> ${PARENT_P}.gh.tar.gz
- "
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~loong ~mips ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
-fi
-
-S="${WORKDIR}/${PARENT_P}/python"
-
-LICENSE="BSD"
-SLOT="0/${PARENT_PV}.0"
-
-DEPEND="${PYTHON_DEPS}
+# Rename sdist to avoid conflicts with dev-libs/protobuf
+SRC_URI="
+ $(pypi_sdist_url)
+ -> ${P}.tar.gz
"
-RDEPEND="
- dev-libs/protobuf:0/${PARENT_PV}.0
-"
-
-distutils_enable_tests setup.py
-
-# Same than PATCHES but from repository's root directory,
-# please see function `python_prepare_all` below.
-# Simplier for users IMHO.
-PARENT_PATCHES=(
-)
-
-# Here for patches within "python/" subdirectory.
-PATCHES=(
-)
-python_prepare_all() {
- pushd "${WORKDIR}/${PARENT_P}" > /dev/null || die
- [[ -n "${PARENT_PATCHES[*]}" ]] && eapply "${PARENT_PATCHES[@]}"
- eapply_user
- popd > /dev/null || die
-
- distutils-r1_python_prepare_all
-}
-
-src_configure() {
- DISTUTILS_ARGS=( --cpp_implementation )
-}
-
-python_compile() {
- distutils-r1_python_compile
- find "${BUILD_DIR}/install" -name "*.pth" -type f -delete || die
-}
+LICENSE="BSD"
+SLOT="0/$(ver_cut 1-3)"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~loong ~mips ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
diff --git a/dev-python/protobuf-python/protobuf-python-9999.ebuild b/dev-python/protobuf-python/protobuf-python-9999.ebuild
deleted file mode 100644
index c8a33b8666b2..000000000000
--- a/dev-python/protobuf-python/protobuf-python-9999.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 2008-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1
-
-PARENT_PN="${PN/-python/}"
-PARENT_PV="$(ver_cut 2-)"
-PARENT_P="${PARENT_PN}-${PARENT_PV}"
-
-if [[ "${PV}" == *9999 ]]; then
- inherit git-r3
-
- EGIT_REPO_URI="https://github.com/protocolbuffers/protobuf.git"
- EGIT_SUBMODULES=()
- EGIT_CHECKOUT_DIR="${WORKDIR}/${PARENT_P}"
-else
- SRC_URI="
- https://github.com/protocolbuffers/protobuf/archive/v${PARENT_PV}.tar.gz
- -> ${PARENT_P}.tar.gz
- "
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~loong ~mips ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux ~x64-macos"
-fi
-
-DESCRIPTION="Google's Protocol Buffers - Python bindings"
-HOMEPAGE="
- https://developers.google.com/protocol-buffers/
- https://pypi.org/project/protobuf/
-"
-
-LICENSE="BSD"
-SLOT="0/23.3.0"
-
-S="${WORKDIR}/${PARENT_P}/python"
-
-BDEPEND="
-"
-DEPEND="
- ${PYTHON_DEPS}
-"
-RDEPEND="
- ${BDEPEND}
- dev-libs/protobuf:${SLOT}
-"
-
-distutils_enable_tests setup.py
-
-# Same than PATCHES but from repository's root directory,
-# please see function `python_prepare_all` below.
-# Simplier for users IMHO.
-PARENT_PATCHES=(
-)
-
-# Here for patches within "python/" subdirectory.
-PATCHES=(
-)
-
-python_prepare_all() {
- pushd "${WORKDIR}/${PARENT_P}" > /dev/null || die
- [[ -n "${PARENT_PATCHES[@]}" ]] && eapply "${PARENT_PATCHES[@]}"
- eapply_user
- popd > /dev/null || die
-
- distutils-r1_python_prepare_all
-}
-
-src_configure() {
- DISTUTILS_ARGS=( --cpp_implementation )
-}
-
-python_compile() {
- distutils-r1_python_compile
- find "${BUILD_DIR}/install" -name "*.pth" -type f -delete || die
-}