summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-08-31 21:20:11 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-08-31 21:20:11 +0300
commitd59ef3ea554ea175b3d4fab340b6492436977fa5 (patch)
tree5d0ee81f79d0f7ab6e3d28362a727e60788475ee /dev-python/proto-plus
parentdev-python/rope: Keyword 1.3.0 x86, #853766 (diff)
downloadgentoo-d59ef3ea554ea175b3d4fab340b6492436977fa5.tar.gz
gentoo-d59ef3ea554ea175b3d4fab340b6492436977fa5.tar.bz2
gentoo-d59ef3ea554ea175b3d4fab340b6492436977fa5.zip
dev-python/proto-plus: add 1.22.1
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/proto-plus')
-rw-r--r--dev-python/proto-plus/Manifest1
-rw-r--r--dev-python/proto-plus/proto-plus-1.22.1.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/proto-plus/Manifest b/dev-python/proto-plus/Manifest
index 1e136ae5825c..9884bc44fdfa 100644
--- a/dev-python/proto-plus/Manifest
+++ b/dev-python/proto-plus/Manifest
@@ -1,2 +1,3 @@
DIST proto-plus-1.20.6.gh.tar.gz 67697 BLAKE2B 88fbf1086bc9430360316c89baaf6216d3f395792fbc2bf1336c22aeb4f912dedd5a4af73c5a10cf6536cdc4cf285c89d1d0a86afd4ee21c7e40b26d34631240 SHA512 5da41a8ddabb34a4083b622d60e59532cd7cb97e4fd243b796aded06ee0f6d9ba5ac847434aa8141b90cb3481d45fbc703de2f905ff4f4676a5d86d77a01c44c
DIST proto-plus-1.22.0.gh.tar.gz 69248 BLAKE2B f0bcfec696fc732eca291452fac681a38c23baa0d67cbca64a1abb31879775d28c00cff0e67e2f6c9f1fe68c3ee2693cc99599bd29f1eb0f17e2f6b48e1c9731 SHA512 110b5cf7effbcec8ac0c99361d1e0710eeea5949d2cc015e6e41cac4d045bf93560eed72b8d83709a76fa57d522859e162e6cc5e60456f98d32761bd284e0d19
+DIST proto-plus-1.22.1.gh.tar.gz 69507 BLAKE2B b71c263270dde979da0e050a21db258366ca5ddfaed5f8fb78e53444454a123d171019801873d1662ca73a89f079fa1c4cb7c58d34053cabb528015c0d742183 SHA512 2fb5dcb6124d6e2aab010089f4ad138de5cd819d4e67c2b9a6d7044a3d7677ca6e5e37e9aa0ee9edb262c52724dfd2dc05592c489df66d3cafbdf51f13644c7e
diff --git a/dev-python/proto-plus/proto-plus-1.22.1.ebuild b/dev-python/proto-plus/proto-plus-1.22.1.ebuild
new file mode 100644
index 000000000000..6be65f5713cd
--- /dev/null
+++ b/dev-python/proto-plus/proto-plus-1.22.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Beautiful, Pythonic protocol buffers"
+HOMEPAGE="
+ https://github.com/googleapis/proto-plus-python/
+ https://pypi.org/project/proto-plus/
+"
+SRC_URI="
+ https://github.com/googleapis/proto-plus-python/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/${PN}-python-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ <dev-python/protobuf-python-5[${PYTHON_USEDEP}]
+ >=dev-python/protobuf-python-3.19.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/google-api-core-1.31.5[${PYTHON_USEDEP}]
+ dev-python/grpcio[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/sphinx_rtd_theme