summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-08 06:22:52 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-08 06:30:55 +0100
commita964d06b541d048f8910d2e574e3546d25803460 (patch)
treed5e00299168f8ada210520921bed9772bc8ce306 /dev-python/proto-plus
parentdev-python/googleapis-common-protos: Bump to 1.62.0 (diff)
downloadgentoo-a964d06b541d048f8910d2e574e3546d25803460.tar.gz
gentoo-a964d06b541d048f8910d2e574e3546d25803460.tar.bz2
gentoo-a964d06b541d048f8910d2e574e3546d25803460.zip
dev-python/proto-plus: Bump to 1.23.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/proto-plus')
-rw-r--r--dev-python/proto-plus/Manifest1
-rw-r--r--dev-python/proto-plus/proto-plus-1.23.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/proto-plus/Manifest b/dev-python/proto-plus/Manifest
index 71bbab0c625c..67fc57dd6e3e 100644
--- a/dev-python/proto-plus/Manifest
+++ b/dev-python/proto-plus/Manifest
@@ -1 +1,2 @@
DIST proto-plus-python-1.22.3.gh.tar.gz 94230 BLAKE2B 7d7def297a2f1b863c4226ed6af35b3ecc6cfac5d324ddc311b5d44189b45773c46b83bf242fa9f9847399e1f6a55d5b114a6a1d69fe170201201fa92747dac7 SHA512 8505656798426d07e27929bf43873ae3f46b1cbd1e1b81e41035382c6edb5e5de4a550e41985d93b3c161a5fc676a1db6fc14b8e74dce5d1b1b7bf3a80419ae4
+DIST proto-plus-python-1.23.0.gh.tar.gz 96752 BLAKE2B a971ef18b3513dcda0f2ea7a1eec8a1b76cc0094fdb73e7df1b258d0db7c16d2ef07152eff28c71e10456e2b9d2532da748901734d35a0245f99af7cf558866c SHA512 9e1566f6e3d2f99a37e7c5c9d3203a0073648f423112413d7d4fd61ebe38f175f30e1c4d2d24257acb7d09a685722b63960f9f686ede9ddb98a4c4463d5c0402
diff --git a/dev-python/proto-plus/proto-plus-1.23.0.ebuild b/dev-python/proto-plus/proto-plus-1.23.0.ebuild
new file mode 100644
index 000000000000..3c91dd1f06fa
--- /dev/null
+++ b/dev-python/proto-plus/proto-plus-1.23.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+MY_P=${PN}-python-${PV}
+DESCRIPTION="Beautiful, Pythonic protocol buffers"
+HOMEPAGE="
+ https://github.com/googleapis/proto-plus-python/
+ https://pypi.org/project/proto-plus/
+"
+SRC_URI="
+ https://github.com/googleapis/proto-plus-python/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ <dev-python/protobuf-python-5[${PYTHON_USEDEP}]
+ >=dev-python/protobuf-python-3.19.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/google-api-core-1.31.5[${PYTHON_USEDEP}]
+ dev-python/grpcio[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/sphinx-rtd-theme