summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-01-05 13:44:15 +0100
committerManuel Rüger <mrueg@gentoo.org>2017-01-05 13:45:17 +0100
commit0cb9e0522de7ef51aaff3e8a5de17742b89376e0 (patch)
tree4b636fd4afeaa448552812b160f5b2176e6265fc /dev-python/prometheus_client
parentwww-client/chromium: dev channel bump (57.0.2970.0) (diff)
downloadgentoo-0cb9e0522de7ef51aaff3e8a5de17742b89376e0.tar.gz
gentoo-0cb9e0522de7ef51aaff3e8a5de17742b89376e0.tar.bz2
gentoo-0cb9e0522de7ef51aaff3e8a5de17742b89376e0.zip
dev-python/prometheus_client: Support twisted-web as well
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-python/prometheus_client')
-rw-r--r--dev-python/prometheus_client/prometheus_client-0.0.18-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/prometheus_client/prometheus_client-0.0.18-r1.ebuild b/dev-python/prometheus_client/prometheus_client-0.0.18-r1.ebuild
new file mode 100644
index 000000000000..58681e0e90e9
--- /dev/null
+++ b/dev-python/prometheus_client/prometheus_client-0.0.18-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+inherit distutils-r1
+
+DESCRIPTION="Python client for the Prometheus monitoring system"
+HOMEPAGE="https://pypi.python.org/pypi/prometheus_client"
+SRC_URI="https://github.com/prometheus/client_python/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+S=${WORKDIR}/client_python-${PV}
+
+RDEPEND="|| ( dev-python/twisted-web dev-python/twisted[${PYTHON_USEDEP}] )"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ pytest || die
+}