summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-11-24 00:34:04 +0100
committerMichał Górny <mgorny@gentoo.org>2020-11-24 08:42:56 +0100
commit1098bd2ffc7eed8b18eec40a5732fd047a1c0e3e (patch)
treead3c6c076275a09209800f40f3b1d7dece6a9161 /dev-python/pony/pony-0.7.14.ebuild
parentdev-python/boto3: Bump to 1.16.24 (diff)
downloadgentoo-1098bd2ffc7eed8b18eec40a5732fd047a1c0e3e.tar.gz
gentoo-1098bd2ffc7eed8b18eec40a5732fd047a1c0e3e.tar.bz2
gentoo-1098bd2ffc7eed8b18eec40a5732fd047a1c0e3e.zip
dev-python/pony: Bump to 0.7.14
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pony/pony-0.7.14.ebuild')
-rw-r--r--dev-python/pony/pony-0.7.14.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/pony/pony-0.7.14.ebuild b/dev-python/pony/pony-0.7.14.ebuild
new file mode 100644
index 000000000000..6de64d60c256
--- /dev/null
+++ b/dev-python/pony/pony-0.7.14.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+inherit distutils-r1
+
+DESCRIPTION="Python ORM with beautiful query syntax"
+HOMEPAGE="
+ https://ponyorm.org/
+ https://github.com/ponyorm/pony/"
+SRC_URI="
+ https://github.com/ponyorm/pony/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ test? ( $(python_gen_impl_dep sqlite) )"
+
+distutils_enable_tests unittest