summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-02-05 20:39:31 +0100
committerJustin Lecher <jlec@gentoo.org>2016-02-05 20:45:03 +0100
commit9e6c6bb051698eb3142dd446de703e8921f4ce8d (patch)
tree9fd0b1ea7148f13befb136ab50d3310f1bef55ee /dev-python/pillow
parentdev-python/wheel: Version Bump (diff)
downloadgentoo-9e6c6bb051698eb3142dd446de703e8921f4ce8d.tar.gz
gentoo-9e6c6bb051698eb3142dd446de703e8921f4ce8d.tar.bz2
gentoo-9e6c6bb051698eb3142dd446de703e8921f4ce8d.zip
dev-python/pillow: Version Bump
Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/pillow')
-rw-r--r--dev-python/pillow/Manifest1
-rw-r--r--dev-python/pillow/pillow-3.1.1.ebuild94
2 files changed, 95 insertions, 0 deletions
diff --git a/dev-python/pillow/Manifest b/dev-python/pillow/Manifest
index 17f4e9d4211d..8bbaae6ecb2b 100644
--- a/dev-python/pillow/Manifest
+++ b/dev-python/pillow/Manifest
@@ -3,3 +3,4 @@ DIST Pillow-2.8.2.zip 9402887 SHA256 57a900c2f30e53ed054adad401ab69643d9ab21e3ac
DIST Pillow-2.9.0.zip 9612840 SHA256 d1db8dfed77547076037d589b598e04f2cbc1a7835d3d3f137bf20c8994854d5 SHA512 d06371fbe67eca66229cdec7896423f55c9335be50698168c7bf4f4635352454b2f946eae90b404c68d6b939ec1d7353916d32bc9964d5b8986b8098381d5180 WHIRLPOOL c664fec07c6634cad37791375fb1cb38b0edd542d93e099703dbc520e0d54125a1f00f205bbcdb8493df4dfd05ae1c2088ba305f23e66f0cc3e309f446c44fa5
DIST Pillow-3.0.0.zip 9947593 SHA256 0024fce578547a3da92579a163bae09b1d9f0baf3cd8e4a893dc6c11e4e624bb SHA512 59dd809160743d2740dfe64743dc674bb4cb6395914048d0d555ccacc7fee1c8f3a114ec39142b5495a0162a74acaadf7ad66694f97c7f221ccffe19cd656928 WHIRLPOOL 0fe2c9af2557278cc855ec7ddb4cfd944fbd1fc3cb2a614e84bd1dfa0c8ba243e60bda863b0b254098bcc7510d62953dbccf1fce88996011327f1059df0b69fb
DIST Pillow-3.1.0.zip 10077136 SHA256 d2cf322edab56fa5cf5400c96a2dbcf7062ef0ba7345ca4c2798be5595e16330 SHA512 4f9608ef7294a27dec78fbf8ea888ecaebea9199f4eb9167ff883b261f37ac4b01b3375e8c93567c9d6bbbacf80775fdd91abc8f0a7ef02528ba89ed858cce7d WHIRLPOOL 4a4eb8bd9a8356580033a39d31db5b86f54ee14f520c3b135ab1e6385730258481d558d28e9ad3b6257fe862508c8a385982b34791ba90da419e06f5657f700d
+DIST Pillow-3.1.1.zip 10351808 SHA256 e784b1a9fc54ae88a7171aef60a38c2ec0dc463f066691765d11748e014ce2a0 SHA512 83dbb651a46ea2c5daa5c7dd32330d50d8f6ad6d11df9526bd68533fd863621f764e0f2f49896bb5df86968fc45201ac28fad770375612dcefa858096c0063d7 WHIRLPOOL a78a3472280e819eb721264ecc7e4e26d574016183fd7c692074b08fed04526179a08b3d1d15a102d7a46e38359c3370e0c309bfb14bbe1096e34f04f491b2d9
diff --git a/dev-python/pillow/pillow-3.1.1.ebuild b/dev-python/pillow/pillow-3.1.1.ebuild
new file mode 100644
index 000000000000..62d6a0d084c0
--- /dev/null
+++ b/dev-python/pillow/pillow-3.1.1.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy )
+PYTHON_REQ_USE='tk?,threads(+)'
+
+inherit distutils-r1 eutils virtualx
+
+MY_PN=Pillow
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Python Imaging Library (fork)"
+HOMEPAGE="https://github.com/python-imaging/Pillow https://pypi.python.org/pypi/Pillow"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.zip"
+
+LICENSE="HPND"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="doc examples jpeg jpeg2k lcms test tiff tk truetype webp zlib"
+
+REQUIRED_USE="test? ( jpeg tiff )"
+
+RDEPEND="
+ jpeg? ( virtual/jpeg:0 )
+ jpeg2k? ( media-libs/openjpeg:2= )
+ lcms? ( media-libs/lcms:2= )
+ tiff? ( media-libs/tiff:0= )
+ truetype? ( media-libs/freetype:2= )
+ webp? ( media-libs/libwebp:0= )
+ zlib? ( sys-libs/zlib:0= )"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx-better-theme[${PYTHON_USEDEP}]
+ >=dev-python/sphinx_rtd_theme-0.1[${PYTHON_USEDEP}]
+ <dev-python/sphinx_rtd_theme-0.2[${PYTHON_USEDEP}]
+ )
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+ "
+
+S="${WORKDIR}/${MY_P}"
+
+# See _render and _clean in Tests/test_imagefont.py
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_prepare_all() {
+ # Disable all the stuff we don't want.
+ local f
+ for f in jpeg lcms tiff tk webp zlib; do
+ if ! use ${f}; then
+ sed -i -e "s:feature.${f} =:& None #:" setup.py || die
+ fi
+ done
+ if ! use truetype; then
+ sed -i -e 's:feature.freetype =:& None #:' setup.py || die
+ fi
+ if ! use jpeg2k; then
+ sed -i -e 's:feature.jpeg2000 =:& None #:' setup.py || die
+ fi
+
+ sed \
+ -e "/required/s:=.*:= set():g" \
+ -e "/if f in/s:'jpeg', 'libz'::g" \
+ -i setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ "${PYTHON}" selftest.py --installed || die "selftest failed with ${EPYTHON}"
+ virtx nosetests -vx Tests/test_*.py
+}
+
+python_install() {
+ python_doheader libImaging/{Imaging.h,ImPlatform.h}
+
+ distutils-r1_python_install
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ use examples && local EXAMPLES=( Scripts/. )
+
+ distutils-r1_python_install_all
+}