summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-10-23 22:32:10 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2024-10-23 22:32:58 +0300
commit85fa77a2ba82a3e3d5554dbbb34c3325a30748e7 (patch)
treef85c91d5f7fc81403e812076aeb4d96dcca135a7 /dev-python/pdm-backend
parentdev-python/frozenlist: add 1.5.0 (diff)
downloadgentoo-85fa77a2ba82a3e3d5554dbbb34c3325a30748e7.tar.gz
gentoo-85fa77a2ba82a3e3d5554dbbb34c3325a30748e7.tar.bz2
gentoo-85fa77a2ba82a3e3d5554dbbb34c3325a30748e7.zip
dev-python/pdm-backend: add 2.4.3
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/pdm-backend')
-rw-r--r--dev-python/pdm-backend/Manifest1
-rw-r--r--dev-python/pdm-backend/pdm-backend-2.4.3.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/dev-python/pdm-backend/Manifest b/dev-python/pdm-backend/Manifest
index 80f72eebdb78..8851b222d230 100644
--- a/dev-python/pdm-backend/Manifest
+++ b/dev-python/pdm-backend/Manifest
@@ -1,3 +1,4 @@
DIST pdm-backend-2.3.3.gh.tar.gz 136942 BLAKE2B 14f2584f22f1c4e08f687c77621269ae1e5acfe4babb1ab427c10d65ff07841b8175479f867870b9a5745db76444ca140a7da497a94c831ca6d0ea1e67b4e88f SHA512 382ad95e2811f1142fee66065f96ede1a646c3e2b9fbfafc6afb17442d3aeccfbf1ff6260952986a025791d3d56a2c4b730decb3cb65e893c25a710e16cbcfc8
DIST pdm-backend-2.4.1.gh.tar.gz 140137 BLAKE2B fba054e7d94544ed6864b28d13bcc57e585d74b37e775ac0ae2d2e7041d6f8e34bdb5fbaff1b3d918ca75a2c4d7165d97024c63b48d2a2e0a0f3444ffef72669 SHA512 50e28e301c38e47c6c6d2e1a3c01a27da06517e40bd04b2809a130f14ec4de6811b28d8480093efa2e8209be2769b886f65106bf9a94297274b6a5853f901964
DIST pdm-backend-2.4.2.gh.tar.gz 143950 BLAKE2B aa7d88af61c3c8ae8f205878ae675e6d9d66525f1f01bd992f8e2ccf572fd4d648806c02bbd61f01678e87995c68409b1150a8193863d13acc5525c7970ea457 SHA512 98470a622344dfa54e4da38936e469beee17da6a324c7109fd9e92c2b2cea42cf298a634040face2ca092083dbad255857b2d47d11652990abf490826e2ffa99
+DIST pdm-backend-2.4.3.gh.tar.gz 146089 BLAKE2B 36f65db90de5b507348a2a8407ae0eec8e1939c6b0fea1181548de910fad2497594e17aee7d478572a32e28260ef15660bddfaec4d921b2975b5a51da031dc1e SHA512 378bc4360140f18dd7f66701da77f4b98ef4bad39c86055f11f4e508b16ebbbbce2188f47dedc05cd43525baf7873fc4565ee98d00d9e65efd9d8fc1820ddc15
diff --git a/dev-python/pdm-backend/pdm-backend-2.4.3.ebuild b/dev-python/pdm-backend/pdm-backend-2.4.3.ebuild
new file mode 100644
index 000000000000..56e40b8910f4
--- /dev/null
+++ b/dev-python/pdm-backend/pdm-backend-2.4.3.ebuild
@@ -0,0 +1,75 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=standalone
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A PEP 517 backend for PDM that supports PEP 621 metadata"
+HOMEPAGE="
+ https://pypi.org/project/pdm-backend/
+ https://github.com/pdm-project/pdm-backend/
+"
+SRC_URI="
+ https://github.com/pdm-project/pdm-backend/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+# see src/pdm/backend/_vendor/vendor.txt
+RDEPEND="
+ >=dev-python/editables-0.5[${PYTHON_USEDEP}]
+ >=dev-python/packaging-24.0[${PYTHON_USEDEP}]
+ >=dev-python/pyproject-metadata-0.9.0_beta7[${PYTHON_USEDEP}]
+ >=dev-python/tomli-w-1.0.0[${PYTHON_USEDEP}]
+
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-2.0.1[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )
+"
+# setuptools are used to build C extensions
+RDEPEND+="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ rm -r src/pdm/backend/_vendor || die
+ find -name '*.py' -exec sed \
+ -e 's:from pdm\.backend\._vendor\.:from :' \
+ -e 's:from pdm\.backend\._vendor ::' \
+ -e 's:import pdm\.backend\._vendor\.:import :' \
+ -i {} + || die
+ distutils-r1_src_prepare
+}
+
+src_compile() {
+ # this must not be set during src_test()
+ local -x PDM_BUILD_SCM_VERSION=${PV}
+ distutils-r1_src_compile
+}
+
+src_test() {
+ git config --global user.email "test@example.com" || die
+ git config --global user.name "Test User" || die
+ distutils-r1_src_test
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -k "not [hg"
+}