summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-07 03:51:53 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-07 03:51:53 +0200
commit90da18bff724d750ccceb373c7da754a94e5c466 (patch)
treebe9ce359207b3638dc6e84c58919fe1fce0c4d5a /dev-python/partd
parentdev-python/nbsphinx: Bump to 0.9.4 (diff)
downloadgentoo-90da18bff724d750ccceb373c7da754a94e5c466.tar.gz
gentoo-90da18bff724d750ccceb373c7da754a94e5c466.tar.bz2
gentoo-90da18bff724d750ccceb373c7da754a94e5c466.zip
dev-python/partd: Bump to 1.4.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/partd')
-rw-r--r--dev-python/partd/Manifest1
-rw-r--r--dev-python/partd/partd-1.4.2.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/partd/Manifest b/dev-python/partd/Manifest
index 92e97254035f..32122a5f64a4 100644
--- a/dev-python/partd/Manifest
+++ b/dev-python/partd/Manifest
@@ -1 +1,2 @@
DIST partd-1.4.1.tar.gz 36272 BLAKE2B 032f30988468d68b5b8a18ceeb28f75c6807bae8ec57a88c50beb1c4ed2f99721d5f50e1002cf74376867f54f5c5dbdaf823b999f8680766f13e8f5f9df74801 SHA512 0bf285a33731d3c000e6c2c1958cda0df21c3a2be31694ac31ce0cc45aa2b31b8631f962c25b9ecac3831474abb5872748bd3348f99e13faadee467a1f164492
+DIST partd-1.4.2.tar.gz 21029 BLAKE2B 47f4129beb7062415f6b7af8b1ad88faa299692abd6691bbb5ae56c991685d3c7ae7cab809c3ea67e90fc054c6018e1ed36ef0cb5be3c755eca06f1bc90fcfbc SHA512 ae7af568ea5c2c6127ea01bcb2a6703305f126414ecce8c648a14d39fd8dac987f6356011b6a61a1b1441f14a189a098bf9fe35f978a5794959e5da409668d2b
diff --git a/dev-python/partd/partd-1.4.2.ebuild b/dev-python/partd/partd-1.4.2.ebuild
new file mode 100644
index 000000000000..8ee284590257
--- /dev/null
+++ b/dev-python/partd/partd-1.4.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Appendable key-value storage"
+HOMEPAGE="
+ https://github.com/dask/partd/
+ https://pypi.org/project/partd/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/locket[${PYTHON_USEDEP}]
+ dev-python/toolz[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/versioneer-0.20[${PYTHON_USEDEP}]
+ test? (
+ dev-python/blosc[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.20.0[${PYTHON_USEDEP}]
+ >=dev-python/pandas-1.3[${PYTHON_USEDEP}]
+ dev-python/pyzmq[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest