summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-01 08:52:20 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-01 10:43:36 +0200
commit59fcb49855a4940931851df95c166e0250a20249 (patch)
tree30a70a51f4e957d4d96d79f80e0e0417cf260dda /dev-python/parso
parenteclass/docs.eclass: invert (B)DEPEND if condition (diff)
downloadgentoo-59fcb49855a4940931851df95c166e0250a20249.tar.gz
gentoo-59fcb49855a4940931851df95c166e0250a20249.tar.bz2
gentoo-59fcb49855a4940931851df95c166e0250a20249.zip
dev-python/parso: Port 0.7.1-r1 to py3.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/parso')
-rw-r--r--dev-python/parso/parso-0.7.1-r1.ebuild12
1 files changed, 11 insertions, 1 deletions
diff --git a/dev-python/parso/parso-0.7.1-r1.ebuild b/dev-python/parso/parso-0.7.1-r1.ebuild
index d06ec052d5b5..7fe736de955c 100644
--- a/dev-python/parso/parso-0.7.1-r1.ebuild
+++ b/dev-python/parso/parso-0.7.1-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} pypy3 )
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
inherit distutils-r1
@@ -17,3 +17,13 @@ KEYWORDS="amd64 ~arm arm64 ~ppc ppc64 ~sparc x86"
distutils_enable_sphinx docs
distutils_enable_tests pytest
+
+python_test() {
+ local deselect=()
+ [[ ${EPYTHON} == python3.10 ]] && deselect+=(
+ # py3.10 changed exception messages
+ test/test_python_errors.py::test_python_exception_matches
+ test/test_python_errors.py::test_default_except_error_postition
+ )
+ epytest ${deselect[@]/#/--deselect }
+}