summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-28 08:43:07 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-28 09:40:27 +0200
commitbd3dabfb549c179cac068fbfaf19bfb3041bd982 (patch)
tree9e23702ae8c584764bff0f250ee653907caf27cc /dev-python/openpyxl
parentdev-python/csvkit: Remove old (diff)
downloadgentoo-bd3dabfb549c179cac068fbfaf19bfb3041bd982.tar.gz
gentoo-bd3dabfb549c179cac068fbfaf19bfb3041bd982.tar.bz2
gentoo-bd3dabfb549c179cac068fbfaf19bfb3041bd982.zip
dev-python/openpyxl: Backport pytest-8 fixes
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/openpyxl')
-rw-r--r--dev-python/openpyxl/files/openpyxl-3.1.2-pytest-8.patch118
-rw-r--r--dev-python/openpyxl/openpyxl-3.1.2.ebuild5
2 files changed, 123 insertions, 0 deletions
diff --git a/dev-python/openpyxl/files/openpyxl-3.1.2-pytest-8.patch b/dev-python/openpyxl/files/openpyxl-3.1.2-pytest-8.patch
new file mode 100644
index 000000000000..72ed1fab7638
--- /dev/null
+++ b/dev-python/openpyxl/files/openpyxl-3.1.2-pytest-8.patch
@@ -0,0 +1,118 @@
+From 517ce7d21194da275f8083fa2fd7de6977dc7e95 Mon Sep 17 00:00:00 2001
+From: Charlie Clark <charlie.clark@clark-consulting.eu>
+Date: Mon, 11 Mar 2024 13:38:08 +0100
+Subject: [PATCH] Looks like pytest has dropped support for unittest setup
+ methods so switched to fixture.
+
+--HG--
+branch : 3.1
+---
+ openpyxl/drawing/tests/test_drawing.py | 46 ++++++++++++++------------
+ 1 file changed, 24 insertions(+), 22 deletions(-)
+
+diff --git a/openpyxl/drawing/tests/test_drawing.py b/openpyxl/drawing/tests/test_drawing.py
+index c4c0712dd..befd2267c 100644
+--- a/openpyxl/drawing/tests/test_drawing.py
++++ b/openpyxl/drawing/tests/test_drawing.py
+@@ -1,20 +1,20 @@
+ # Copyright (c) 2010-2024 openpyxl
+
+ import pytest
+-
+ from openpyxl.xml.functions import tostring
+-
+ from openpyxl.tests.helper import compare_xml
+
++@pytest.fixture
++def Drawing():
++ from ..drawing import Drawing
++ return Drawing
++
+
+ class TestDrawing(object):
+
+- def setup(self):
+- from ..drawing import Drawing
+- self.drawing = Drawing()
+
+- def test_ctor(self):
+- d = self.drawing
++ def test_ctor(self, Drawing):
++ d = Drawing()
+ assert d.coordinates == ((1, 2), (16, 8))
+ assert d.width == 21
+ assert d.height == 192
+@@ -26,34 +26,34 @@ class TestDrawing(object):
+ assert d.description == ""
+ assert d.name == ""
+
+- def test_width(self):
+- d = self.drawing
++ def test_width(self, Drawing):
++ d = Drawing()
+ d.width = 100
+ d.height = 50
+ assert d.width == 100
+
+- def test_proportional_width(self):
+- d = self.drawing
++ def test_proportional_width(self, Drawing):
++ d = Drawing()
+ d.resize_proportional = True
+ d.width = 100
+ d.height = 50
+ assert (d.width, d.height) == (5, 50)
+
+- def test_height(self):
+- d = self.drawing
++ def test_height(self, Drawing):
++ d = Drawing()
+ d.height = 50
+ d.width = 100
+ assert d.height == 50
+
+- def test_proportional_height(self):
+- d = self.drawing
++ def test_proportional_height(self, Drawing):
++ d = Drawing()
+ d.resize_proportional = True
+ d.height = 50
+ d.width = 100
+ assert (d.width, d.height) == (100, 1000)
+
+- def test_set_dimension(self):
+- d = self.drawing
++ def test_set_dimension(self, Drawing):
++ d = Drawing()
+ d.resize_proportional = True
+ d.set_dimension(100, 50)
+ assert d.width == 6
+@@ -65,8 +65,9 @@ class TestDrawing(object):
+
+
+ @pytest.mark.pil_required
+- def test_absolute_anchor(self):
+- node = self.drawing.anchor
++ def test_absolute_anchor(self, Drawing):
++ drawing = Drawing()
++ node = drawing.anchor
+ xml = tostring(node.to_tree())
+ expected = """
+ <absoluteAnchor>
+@@ -80,9 +81,10 @@ class TestDrawing(object):
+
+
+ @pytest.mark.pil_required
+- def test_onecell_anchor(self):
+- self.drawing.anchortype = "oneCell"
+- node = self.drawing.anchor
++ def test_onecell_anchor(self, Drawing):
++ drawing = Drawing()
++ drawing.anchortype = "oneCell"
++ node = drawing.anchor
+ xml = tostring(node.to_tree())
+ expected = """
+ <oneCellAnchor>
+--
+GitLab
+
diff --git a/dev-python/openpyxl/openpyxl-3.1.2.ebuild b/dev-python/openpyxl/openpyxl-3.1.2.ebuild
index bc945c3d872d..c13c49087681 100644
--- a/dev-python/openpyxl/openpyxl-3.1.2.ebuild
+++ b/dev-python/openpyxl/openpyxl-3.1.2.ebuild
@@ -35,6 +35,11 @@ distutils_enable_sphinx doc \
dev-python/sphinx-rtd-theme
distutils_enable_tests pytest
+PATCHES=(
+ # https://foss.heptapod.net/openpyxl/openpyxl/-/commit/517ce7d21194da275f8083fa2fd7de6977dc7e95
+ "${FILESDIR}/${P}-pytest-8.patch"
+)
+
python_test() {
local EPYTEST_DESELECT=()