summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-11-22 15:52:57 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-11-22 16:00:55 +0100
commit5c57d63fafc8b54bdf2646834ac7d98c22d86fbc (patch)
treeb7250e9e02ae54ca35ca892f6249110ee6e1a573 /dev-python/numexpr
parentgames-strategy/0ad: filter lto flag (diff)
downloadgentoo-5c57d63fafc8b54bdf2646834ac7d98c22d86fbc.tar.gz
gentoo-5c57d63fafc8b54bdf2646834ac7d98c22d86fbc.tar.bz2
gentoo-5c57d63fafc8b54bdf2646834ac7d98c22d86fbc.zip
dev-python/numexpr: use python_get_sitedir for tests
The tests still fail with pypy3, but at least with this change it doesn't error out on the pushd Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/numexpr')
-rw-r--r--dev-python/numexpr/numexpr-2.8.7.ebuild2
1 files changed, 1 insertions, 1 deletions
diff --git a/dev-python/numexpr/numexpr-2.8.7.ebuild b/dev-python/numexpr/numexpr-2.8.7.ebuild
index 5e14c17b6ffa..fc5b7013cbbb 100644
--- a/dev-python/numexpr/numexpr-2.8.7.ebuild
+++ b/dev-python/numexpr/numexpr-2.8.7.ebuild
@@ -30,7 +30,7 @@ RDEPEND="
"
python_test() {
- pushd "${BUILD_DIR}/install/usr/lib/${EPYTHON}/site-packages" >/dev/null || die
+ pushd "${BUILD_DIR}/install/$(python_get_sitedir)" >/dev/null || die
"${EPYTHON}" - <<-EOF || die "Tests failed with ${EPYTHON}"
import sys,numexpr
sys.exit(0 if numexpr.test().wasSuccessful() else 1)