summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-29 16:36:08 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-29 16:43:45 +0100
commit261ad61f2235d32f95d9ae9667fd87191829f38c (patch)
treec3fb20267409bb0a07bb1a82102f711ce76e5958 /dev-python/notify2
parentdev-python/nbformat: Switch to PEP 517 build (diff)
downloadgentoo-261ad61f2235d32f95d9ae9667fd87191829f38c.tar.gz
gentoo-261ad61f2235d32f95d9ae9667fd87191829f38c.tar.bz2
gentoo-261ad61f2235d32f95d9ae9667fd87191829f38c.zip
dev-python/notify2: Switch to PEP 517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/notify2')
-rw-r--r--dev-python/notify2/notify2-0.3.1-r3.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/notify2/notify2-0.3.1-r3.ebuild b/dev-python/notify2/notify2-0.3.1-r3.ebuild
new file mode 100644
index 000000000000..18e4358229b8
--- /dev/null
+++ b/dev-python/notify2/notify2-0.3.1-r3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Python interface to DBus notifications"
+HOMEPAGE="https://bitbucket.org/takluyver/pynotify2"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="examples"
+
+RDEPEND="dev-python/dbus-python[${PYTHON_USEDEP}]"
+BDEPEND="test? (
+ dev-python/pygobject[${PYTHON_USEDEP}]
+ sys-apps/dbus[X]
+ x11-libs/gdk-pixbuf[introspection]
+ virtual/notification-daemon
+)"
+
+distutils_enable_tests unittest
+
+python_test() {
+ virtx eunittest
+}
+
+python_install_all() {
+ if use examples; then
+ rm examples/notify2.py || die
+ dodoc -r examples
+ fi
+ distutils-r1_python_install_all
+}