summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2021-11-14 02:45:56 +0100
committerThomas Deutschmann <whissi@gentoo.org>2021-11-14 04:49:48 +0100
commitae3b1f5490cc2fee0357e602c5e77fdfdd16e899 (patch)
tree6d69b294be0e153ca66466e306fcfab1919dd9f9 /dev-python/mysql-connector-python
parentdev-db/mysql-connector-c: bump to v8.0.27 (diff)
downloadgentoo-ae3b1f5490cc2fee0357e602c5e77fdfdd16e899.tar.gz
gentoo-ae3b1f5490cc2fee0357e602c5e77fdfdd16e899.tar.bz2
gentoo-ae3b1f5490cc2fee0357e602c5e77fdfdd16e899.zip
dev-python/mysql-connector-python: bump to v8.0.27
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-python/mysql-connector-python')
-rw-r--r--dev-python/mysql-connector-python/Manifest1
-rw-r--r--dev-python/mysql-connector-python/mysql-connector-python-8.0.27.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/mysql-connector-python/Manifest b/dev-python/mysql-connector-python/Manifest
index 4f171f1d7da1..4741b1fa5ab5 100644
--- a/dev-python/mysql-connector-python/Manifest
+++ b/dev-python/mysql-connector-python/Manifest
@@ -1 +1,2 @@
DIST mysql-connector-python-8.0.26.tar.gz 15180658 BLAKE2B e964728d5f39b9ca5abc72ab84780b463708d1a1cf90507330e73be4837cd30befe245ddd70783490660c70da1b7c162803eee743a0e668cfa6b82773bea4fef SHA512 204021e08b21c5efe87c0f59a6ff3b949cc1d01005121dfe5dde7fea12852a3e28c35b68e06e04f2c0ac4f911bfc14893e6509c99d0c5bf2c30fa32d4131c630
+DIST mysql-connector-python-8.0.27.tar.gz 15202354 BLAKE2B dd9d3b931d88955af3e0d9ec1e12136dabc475ac45ed3d7d0fec42d6f966b38d69c1ee13a96f7173e4c8754656255279c5ab7e41cc5a31b3b7129b20cc617ba9 SHA512 3ba5beff16e743f7098e211cbde35bea7bc7451cf77c544b60beeebcb2c9724f3afd5ab6ff6f9d9809075f4cf29e42f40cd326be944408942d06d357f6a95a23
diff --git a/dev-python/mysql-connector-python/mysql-connector-python-8.0.27.ebuild b/dev-python/mysql-connector-python/mysql-connector-python-8.0.27.ebuild
new file mode 100644
index 000000000000..454f690c682b
--- /dev/null
+++ b/dev-python/mysql-connector-python/mysql-connector-python-8.0.27.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+inherit distutils-r1
+
+DESCRIPTION="Python client library for MariaDB/MySQL"
+HOMEPAGE="https://dev.mysql.com/downloads/connector/python/"
+SRC_URI="https://github.com/mysql/mysql-connector-python/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~arm ~x86"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="examples test"
+
+BDEPEND=">=dev-libs/protobuf-3.6.1"
+
+RDEPEND="
+ >=dev-db/mysql-connector-c-8.0
+ >=dev-python/protobuf-python-3.6.1[${PYTHON_USEDEP}]
+ dev-python/dnspython[${PYTHON_USEDEP}]
+"
+# tests/mysqld.py does not like MariaDB version strings.
+# See the regex MySQLServerBase._get_version.
+DEPEND="${RDEPEND} test? ( dev-db/mysql[server(+)] )"
+
+# Tests currently fail.
+# mysql.connector.errors.DatabaseError: 1300 (HY000): Invalid utf8 character string: ''
+RESTRICT="test"
+
+DOCS=( README.txt CHANGES.txt README.rst )
+
+python_test() {
+ "${EPYTHON}" unittests.py --with-mysql="${EPREFIX}/usr" --unix-socket="${T}" --mysql-topdir="${T}"
+}
+
+# Yeah, this is really broken, but the extension will only build this way during "install"
+python_install() {
+ distutils-r1_python_install \
+ --with-mysql-capi="${EPREFIX}/usr" \
+ --with-protobuf-include-dir="${EPREFIX}/usr/include/google/protobuf/" \
+ --with-protobuf-lib-dir="${EPREFIX}/usr/$(get_libdir)" \
+ --with-protoc="${EPREFIX}/usr/bin/protoc"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if use examples ; then
+ dodoc -r examples
+ fi
+}