summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-09 20:34:25 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-09 20:34:47 +0200
commit4f5969e2d53028464c86c37e38f882d73299f471 (patch)
treeff2c103736e0890114eb75ed7dc90d06c3667efe /dev-python/mkdocs
parentdev-python/regex: Stabilize 2022.3.15 hppa, #837461 (diff)
downloadgentoo-4f5969e2d53028464c86c37e38f882d73299f471.tar.gz
gentoo-4f5969e2d53028464c86c37e38f882d73299f471.tar.bz2
gentoo-4f5969e2d53028464c86c37e38f882d73299f471.zip
dev-python/mkdocs: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/mkdocs')
-rw-r--r--dev-python/mkdocs/Manifest1
-rw-r--r--dev-python/mkdocs/mkdocs-1.2.3.ebuild73
2 files changed, 0 insertions, 74 deletions
diff --git a/dev-python/mkdocs/Manifest b/dev-python/mkdocs/Manifest
index 6b5df73196ca..63b4b1754e16 100644
--- a/dev-python/mkdocs/Manifest
+++ b/dev-python/mkdocs/Manifest
@@ -1,2 +1 @@
-DIST mkdocs-1.2.3.tar.gz 6919177 BLAKE2B 43ff118149a497dd366f7132487564be51ffeaff644a519c7bf9e52a3e3239e9696c21616e5d7494f7c4af8ee60ec77f27fd15e80f5c5c6c1b2db4cf1f672e44 SHA512 03385bc940df8a6b3668300f3752afe973b95f149bee58217ace82063aacb661dbd000a2a7a383c4804434473c3945cec3cb41d6608388350da3098c32709541
DIST mkdocs-1.3.0.tar.gz 4085674 BLAKE2B e34605c2d1122ff86ed5cfb6134cdda67450e8f32d7628626ff4ac8c36c45b127312ad693efe35237b714adb9efd244f12f90cf8ecacf6009b75786db30ebb1b SHA512 d33d728eaff4e39106c1187cf04f579706ce28af364852c67706ab85f6b9ccdcd26ae84cd4d5ea7572e52fde1d1137eb3e424679dd4c8ef043c9637aac062270
diff --git a/dev-python/mkdocs/mkdocs-1.2.3.ebuild b/dev-python/mkdocs/mkdocs-1.2.3.ebuild
deleted file mode 100644
index 228eea42ffd4..000000000000
--- a/dev-python/mkdocs/mkdocs-1.2.3.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="Project documentation with Markdown"
-HOMEPAGE="https://www.mkdocs.org https://github.com/mkdocs/mkdocs"
-SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~riscv x86"
-
-IUSE="doc"
-
-BDEPEND="
- doc? (
- $(python_gen_any_dep '
- dev-python/mdx_gh_links[${PYTHON_USEDEP}]
- dev-python/mkdocs-redirects[${PYTHON_USEDEP}]
- ')
- )
-"
-
-RDEPEND="
- >=dev-python/Babel-2.9.0[${PYTHON_USEDEP}]
- >=dev-python/click-3.3[${PYTHON_USEDEP}]
- >=dev-python/jinja-2.10.1[${PYTHON_USEDEP}]
- >=dev-python/markdown-3.2.1[${PYTHON_USEDEP}]
- >=dev-python/pyyaml-3.10[${PYTHON_USEDEP}]
- >=dev-python/watchdog-2.0[${PYTHON_USEDEP}]
- >=dev-python/ghp-import-1.0[${PYTHON_USEDEP}]
- >=dev-python/pyyaml_env_tag-0.1[${PYTHON_USEDEP}]
- >=dev-python/importlib_metadata-3.10[${PYTHON_USEDEP}]
- >=dev-python/packaging-20.5[${PYTHON_USEDEP}]
- >=dev-python/mergedeep-1.3.4[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests --install nose
-
-python_prepare_all() {
- # Tests fails if additional themes are installed
- sed -i -e 's:test_get_themes:_&:' \
- mkdocs/tests/utils/utils_tests.py || die
-
- # Skip this network test, "does not appear to be an IPv4 or IPv6 address"
- sed -i -e 's/test_IP_normalization/_&/' \
- mkdocs/tests/config/config_options_tests.py || die
-
- # livereload has been dropped in this release, this test is a remnant
- rm mkdocs/tests/livereload_tests.py || die
-
- # fix apparent typo in test (importing wrong thing)
- sed -i -e 's/from localization import/from mkdocs.localization import/g' \
- mkdocs/tests/theme_tests.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- default
- if use doc; then
- # cannot just do mkdocs build, because that fails if
- # the package isn't already installed
- python -m mkdocs build || die "Failed to make docs"
- # Colliding files found by ecompress:
- rm site/sitemap.xml.gz || die
- HTML_DOCS=( "site/." )
- fi
-}