summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-11 04:38:34 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-11 05:14:26 +0200
commita265cb1d0e3d2c47a42f1a7da5a16871f94beb68 (patch)
treede77d684926c74eec7193045ea2f7c80ae926f01 /dev-python/loguru
parentdev-python/pytest-sugar: Bump to 0.9.7 (diff)
downloadgentoo-a265cb1d0e3d2c47a42f1a7da5a16871f94beb68.tar.gz
gentoo-a265cb1d0e3d2c47a42f1a7da5a16871f94beb68.tar.bz2
gentoo-a265cb1d0e3d2c47a42f1a7da5a16871f94beb68.zip
dev-python/loguru: Bump to 0.7.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/loguru')
-rw-r--r--dev-python/loguru/Manifest1
-rw-r--r--dev-python/loguru/loguru-0.7.0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/loguru/Manifest b/dev-python/loguru/Manifest
index cfbef3d5e706..45dda10e1dec 100644
--- a/dev-python/loguru/Manifest
+++ b/dev-python/loguru/Manifest
@@ -1,2 +1,3 @@
DIST loguru-0.6.0-py311-repr-tests.patch 4251 BLAKE2B 21891ede1845387f915d3889dfb077af78e88909ce7efe25cd194516dab465738d3c398195552e8a8a54913804df1bc74bf95c4e12494b8e7f628894d0c12177 SHA512 e1da062ba49e53ecfedc044d59f969797bd1dec99c64e42d5420af6cba80db95d242ed7d155b180e84dacba4bd56298fd5a4cae784ef4eec1709905da1a1c93f
DIST loguru-0.6.0.gh.tar.gz 417660 BLAKE2B a7b7d95ffcf652769503db3423768ff85a4fa4898f0e2b155d96ce0c42fa7f24255f9dc49ba62e8a4f19bb3b7cc8b374580fe0965c9683b14d9bcea9866e71a5 SHA512 6ca7087cde3b4ce11255e31af988e5e118a7ebfbb338b97ebd6e7e4af716f0301c0180a59b18c879fd799c25802b428411b868290b7593212f06d70bcbd6a9ca
+DIST loguru-0.7.0.gh.tar.gz 430544 BLAKE2B 13ee91da7c7bc0b29297cb70235c26e0517939c332dde342c14cb937112d5a0b9c467ec273f2034875a52902ffc05dd780fd349498d8a0b65efd6ecf6a947056 SHA512 02d2a0c7c54a5083a444a23222854ee4587da3f7a490ec193d0bae2f3c464c0a86102417f5886205e73c0a149694b931f39f3c5a1ade605cf2b2799395a478a0
diff --git a/dev-python/loguru/loguru-0.7.0.ebuild b/dev-python/loguru/loguru-0.7.0.ebuild
new file mode 100644
index 000000000000..f776f2759d43
--- /dev/null
+++ b/dev-python/loguru/loguru-0.7.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python logging made (stupidly) simple"
+HOMEPAGE="
+ https://github.com/Delgan/loguru/
+ https://pypi.org/project/loguru/
+"
+SRC_URI="
+ https://github.com/Delgan/loguru/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+BDEPEND="
+ test? (
+ >=dev-python/colorama-0.4.6[${PYTHON_USEDEP}]
+ >=dev-python/freezegun-1.2.2[${PYTHON_USEDEP}]
+ )
+"
+
+# filesystem buffering tests may fail
+# on tmpfs with 64k PAGESZ, but pass fine on ext4
+distutils_enable_tests pytest