summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-20 07:14:34 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-20 07:38:25 +0200
commitcdfcebc30a2a8cf5fefbb883c7cc52423ca4a77c (patch)
tree67ca6bae3203ca113551e7183078b3a63868945b /dev-python/keystoneauth1
parentdev-python/griffe: Bump to 0.29.1 (diff)
downloadgentoo-cdfcebc30a2a8cf5fefbb883c7cc52423ca4a77c.tar.gz
gentoo-cdfcebc30a2a8cf5fefbb883c7cc52423ca4a77c.tar.bz2
gentoo-cdfcebc30a2a8cf5fefbb883c7cc52423ca4a77c.zip
dev-python/keystoneauth1: Bump to 5.2.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/keystoneauth1')
-rw-r--r--dev-python/keystoneauth1/Manifest1
-rw-r--r--dev-python/keystoneauth1/keystoneauth1-5.2.1.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/keystoneauth1/Manifest b/dev-python/keystoneauth1/Manifest
index 1e495cacf950..55326ae5cfe6 100644
--- a/dev-python/keystoneauth1/Manifest
+++ b/dev-python/keystoneauth1/Manifest
@@ -1 +1,2 @@
DIST keystoneauth1-5.2.0.tar.gz 273102 BLAKE2B ed05830fad8432c36bff41b2238f91cea69846074da9991e28d75ac2ea00744f811edf33f84a2b3e4b4476de1dee8ecf85cfc7d6dbb01ab733d48a84bed80646 SHA512 4a9818922a7f899ebfb2f80a1cde4e4e62a94c30788f7e79004a24de8f94c7d9e0ce9e15eb3a37137240bb4ae0dcc71620edc7bdc05f83323939a48a075b6031
+DIST keystoneauth1-5.2.1.tar.gz 273214 BLAKE2B 1edeaf982dbdf9c4c0d3ba15762a37104bd355bc5de848d05bbc1d51b914875f8ff47be3777f57e03b10a0ad837f29c1ad8df8666a4839a51688afd6894706be SHA512 912833a84cc47e13db851cfd34e6d4e74d3f3594f15c5e5a94c318d7a720145cc226a85921a7aed6e1385b4b260fc3f966a1d558d5165af3bc39ed87e2a148ba
diff --git a/dev-python/keystoneauth1/keystoneauth1-5.2.1.ebuild b/dev-python/keystoneauth1/keystoneauth1-5.2.1.ebuild
new file mode 100644
index 000000000000..b0f8223e4c1a
--- /dev/null
+++ b/dev-python/keystoneauth1/keystoneauth1-5.2.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="This package contains tools for authenticating to an OpenStack-based cloud"
+HOMEPAGE="https://github.com/openstack/keystoneauth"
+HOMEPAGE="
+ https://opendev.org/openstack/keystoneauth/
+ https://github.com/openstack/keystoneauth/
+ https://pypi.org/project/keystoneauth1/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/iso8601-0.1.11[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+ >=dev-python/os-service-types-1.2.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/betamax-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/lxml-4.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oauthlib-0.6.2[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-5.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.12[${PYTHON_USEDEP}]
+ >=dev-python/requests-kerberos-0.8.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-mock-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/testresources-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ # relies on specific test runner name
+ sed -i -e 's:run\.py:unittest_or_fail.py:' \
+ keystoneauth1/tests/unit/test_session.py || die
+ # remove the test that requires hacking
+ rm keystoneauth1/tests/unit/test_hacking_checks.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ eunittest -b
+}