summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-21 07:23:21 +0200
committerMichał Górny <mgorny@gentoo.org>2022-10-21 09:48:13 +0200
commit2d3e27007d2ac7dc28e2bb28c14ec7de8bb2da6b (patch)
tree9a35b306dd58a1295c0d71dd2c44eec1f1919c12 /dev-python/jupyterlab_server
parentdev-python/nuitka: Bump to 1.1.6 (diff)
downloadgentoo-2d3e27007d2ac7dc28e2bb28c14ec7de8bb2da6b.tar.gz
gentoo-2d3e27007d2ac7dc28e2bb28c14ec7de8bb2da6b.tar.bz2
gentoo-2d3e27007d2ac7dc28e2bb28c14ec7de8bb2da6b.zip
dev-python/jupyterlab_server: Bump to 2.16.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jupyterlab_server')
-rw-r--r--dev-python/jupyterlab_server/Manifest1
-rw-r--r--dev-python/jupyterlab_server/jupyterlab_server-2.16.1.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/jupyterlab_server/Manifest b/dev-python/jupyterlab_server/Manifest
index 1456ce5ec2b3..69f8d70a8e86 100644
--- a/dev-python/jupyterlab_server/Manifest
+++ b/dev-python/jupyterlab_server/Manifest
@@ -3,3 +3,4 @@ DIST jupyterlab_server-2.15.0.tar.gz 61443 BLAKE2B 48ead96f13caf747cc14f7d65dc61
DIST jupyterlab_server-2.15.1.tar.gz 62345 BLAKE2B 14d82bc9cc7566312c4f434b78f396bb822f150653e3be6f1e328d620d1d8b205a8dca8c0b4a1e84a52562e04f76cb63154fd1b58f45da3a4f787a32468595cc SHA512 b4fba8a09562a70a705170406b69cbfaad4fcee290ca74e7949155698af616e4ce650a75c06bfa613e1a307980a4769418587ccf33a964868053ded9a7648095
DIST jupyterlab_server-2.15.2.tar.gz 62533 BLAKE2B 46df68a0f1500e1b4520817ee63042194e65e72fb9d63058bc18effad1668e19733e6a1d5edbd2ec6e07c4c932c2901d974f787455142404f8162d2a83205f68 SHA512 670b9cb3a982d832225a7e632dda57000044a5a4b86f4d0c308cc20c1ad8db09216ae3918af52209dd3bfb04d34c807fca7060208db239b52ef9f29b92943ead
DIST jupyterlab_server-2.16.0.tar.gz 62546 BLAKE2B ce8c1d8aa906d61ebdfccbcdd851a26df09c39a4dbdbe84297889b6a28960eb7616de049b6a6cab6188ae4392535f1e45f60f4699b52ce9eea4071c9b89d7745 SHA512 13df24cf3b77d74b64cbacb6d0d9f385e2e09adc77dc223a0ebaa56585c29f7fcf3f91c0091c4d3354dc0059ba1126cf813c74119f3c8f6a6244b9d1f0ab43e2
+DIST jupyterlab_server-2.16.1.tar.gz 64634 BLAKE2B 05d71b229b9e226bcae409028ff97fa6313662b506171ee5fcb3d8a0cb29c6339f5a54ce91a31b251e969d1418d1a6ede61ccefb1be5412f35bbe51d34378fcf SHA512 3841463b56adcca2d65a9943e04c084fef47b208b46012c9e01a3f91d58058d0bc8e0e97dd1c794ebc7963fc7106f4965524ba293268bb4e7a2e41158a7c54cf
diff --git a/dev-python/jupyterlab_server/jupyterlab_server-2.16.1.ebuild b/dev-python/jupyterlab_server/jupyterlab_server-2.16.1.ebuild
new file mode 100644
index 000000000000..246f5dbfdff8
--- /dev/null
+++ b/dev-python/jupyterlab_server/jupyterlab_server-2.16.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_PEP517=hatchling
+
+inherit distutils-r1
+
+DESCRIPTION="Server components for JupyterLab and JupyterLab like applications"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyterlab/jupyterlab_server/
+ https://pypi.org/project/jupyterlab-server/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/Babel[${PYTHON_USEDEP}]
+ >=dev-python/jinja-3.0.3[${PYTHON_USEDEP}]
+ dev-python/json5[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.0.1[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ >=dev-python/jupyter_server-1.8[${PYTHON_USEDEP}]
+ <dev-python/jupyter_server-3[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/importlib_metadata-4.8.3[${PYTHON_USEDEP}]
+ ' 3.8 3.9)
+"
+
+BDEPEND="
+ test? (
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/jupyter_server[${PYTHON_USEDEP}]
+ >=dev-python/openapi-core-0.14.2[${PYTHON_USEDEP}]
+ <dev-python/openapi-core-0.15[${PYTHON_USEDEP}]
+ dev-python/openapi-spec-validator[${PYTHON_USEDEP}]
+ dev-python/pytest-tornasync[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+ dev-python/strict-rfc3339[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+# TODO: package autodoc_traits
+#distutils_enable_sphinx docs/source dev-python/pydata-sphinx-theme dev-python/myst_parser
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ tests/test_translation_api.py
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p pytest_tornasync.plugin
+}