summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-08-26 18:55:47 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-08-26 18:55:47 +0300
commit126802464c79546b96a164295ba4475ca288cca9 (patch)
tree284af26ecbc4400c3797316a6689e09b3cc14093 /dev-python/jupyterlab-lsp
parentdev-python/setuptools: add 65.3.0 (diff)
downloadgentoo-126802464c79546b96a164295ba4475ca288cca9.tar.gz
gentoo-126802464c79546b96a164295ba4475ca288cca9.tar.bz2
gentoo-126802464c79546b96a164295ba4475ca288cca9.zip
dev-python/jupyterlab-lsp: add 3.10.2
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/jupyterlab-lsp')
-rw-r--r--dev-python/jupyterlab-lsp/Manifest1
-rw-r--r--dev-python/jupyterlab-lsp/jupyterlab-lsp-3.10.2.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/jupyterlab-lsp/Manifest b/dev-python/jupyterlab-lsp/Manifest
index 088b4f440bd6..515e6c06a778 100644
--- a/dev-python/jupyterlab-lsp/Manifest
+++ b/dev-python/jupyterlab-lsp/Manifest
@@ -1 +1,2 @@
DIST jupyterlab-lsp-3.10.1.tar.gz 269339 BLAKE2B 18949cb5b2ae73b1beb623756d9aa316192ea0ba5074edc106e3acd8a3cc6e0803c01727ce4416a3ba0f6b2fc88def2d4c93deead33ca55c4735e8a45c48afd9 SHA512 56fccdc383ebf12572dc61f37d76c0a6aaa0021fea75ead7dbf51e9eba7e25986d9f3752f1146b6dc2cad8c565026e7354cd0c56bf32607421c6a4de0f9b5da6
+DIST jupyterlab-lsp-3.10.2.tar.gz 269490 BLAKE2B 43e4c79e94f85497f83c8034d63164ae5e0820dba6a725048c7f11522d2ab98326e637c254251e96d72d35d7ff8962ab8750a2ba42681c4ef34a65bbb42240d4 SHA512 e154b1f382d2a70a3378f821b055d9a05e9ba748f3ca3e61974655ec3a06f73bc864ad18917171e1101692760fab44b830d2eb70676961a09e383b3544d8ba71
diff --git a/dev-python/jupyterlab-lsp/jupyterlab-lsp-3.10.2.ebuild b/dev-python/jupyterlab-lsp/jupyterlab-lsp-3.10.2.ebuild
new file mode 100644
index 000000000000..46148aa982dc
--- /dev/null
+++ b/dev-python/jupyterlab-lsp/jupyterlab-lsp-3.10.2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Coding assistance for JupyterLab with Language Server Protocol"
+HOMEPAGE="https://github.com/jupyter-lsp/jupyterlab-lsp"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/jupyterlab-3.1.0[${PYTHON_USEDEP}]
+ <dev-python/jupyterlab-4.0.0[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-lsp-1.4.0[${PYTHON_USEDEP}]
+"