summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-08-20 17:58:30 +0200
committerMichał Górny <mgorny@gentoo.org>2023-08-20 17:58:30 +0200
commita54f91a369524c0f6349f4fa040f05eb939fdfa2 (patch)
tree600890422f28b80946fb15853bedd923673e0190 /dev-python/jupyter-server
parentkernel-build.class: Allow usage with module-less kernel configs (diff)
downloadgentoo-a54f91a369524c0f6349f4fa040f05eb939fdfa2.tar.gz
gentoo-a54f91a369524c0f6349f4fa040f05eb939fdfa2.tar.bz2
gentoo-a54f91a369524c0f6349f4fa040f05eb939fdfa2.zip
dev-python/jupyter-server: Bump to 2.7.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jupyter-server')
-rw-r--r--dev-python/jupyter-server/Manifest1
-rw-r--r--dev-python/jupyter-server/jupyter-server-2.7.2.ebuild77
2 files changed, 78 insertions, 0 deletions
diff --git a/dev-python/jupyter-server/Manifest b/dev-python/jupyter-server/Manifest
index 6100e416421a..e57330a5d22a 100644
--- a/dev-python/jupyter-server/Manifest
+++ b/dev-python/jupyter-server/Manifest
@@ -1,2 +1,3 @@
DIST jupyter_server-2.5.0.tar.gz 694029 BLAKE2B bea1082709653617c812124378e1e2a639e90b1e0d7fedacd98628c415adad2daa5343b57a19a776c41820e6665c8591c8d2a652f8c791b605bc3a4b65400ef3 SHA512 7145f60a73bf3d9aceff37aaf56b3b3a54c94fd9f13f06659387909cb1727759a082d11e983df4e687cc508461d5afb6e552f3ac09e30bebb1eb5e863992ad14
DIST jupyter_server-2.7.0.tar.gz 704548 BLAKE2B d328b3254143191627d3f743a2ceb1ef16216e04db714ee75bb7e0002c3cb238b8ec7c7f06599ebb1e9a0b000dcb00c7844bc2c894f450bdf3e99d209dbb9106 SHA512 e8d9ec3b65b25844fbd8e5353a6d1899c07d83ce446c70cae563652b35761d8cbba5d9f5dd52c390e8294dddd70710383e615a7ca07f5e6836ec69708496eb7c
+DIST jupyter_server-2.7.2.tar.gz 705360 BLAKE2B fc896756caccacba82a65dbaf68f2e2e3dac816e22360b0a24b495fb54958925b85b71be2fbd552654fd5d588739b42ad18495b4ff1df3ac7628fa6d7a970a98 SHA512 ea3b968a742c47e90451e4d701801895ec16304705d65d48609a803934a77143ccff21de697aef061c1e0b9829c122ace0d1d9bdd5889bebbb58a9e6cda35e1f
diff --git a/dev-python/jupyter-server/jupyter-server-2.7.2.ebuild b/dev-python/jupyter-server/jupyter-server-2.7.2.ebuild
new file mode 100644
index 000000000000..801348263ba4
--- /dev/null
+++ b/dev-python/jupyter-server/jupyter-server-2.7.2.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Core services, APIs, and REST endpoints to Jupyter web applications"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyter-server/jupyter_server/
+ https://pypi.org/project/jupyter-server/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~s390"
+
+RDEPEND="
+ >=dev-python/anyio-3.1.0[${PYTHON_USEDEP}]
+ dev-python/argon2-cffi[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-client-7.4.4[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-core-5.1.0[${PYTHON_USEDEP}]
+ dev-python/jupyter-server-terminals[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-events-0.6.0[${PYTHON_USEDEP}]
+ >=dev-python/nbconvert-6.4.4[${PYTHON_USEDEP}]
+ >=dev-python/nbformat-5.3.0[${PYTHON_USEDEP}]
+ dev-python/overrides[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/prometheus-client[${PYTHON_USEDEP}]
+ >=dev-python/pyzmq-24[${PYTHON_USEDEP}]
+ >=dev-python/send2trash-1.8.2[${PYTHON_USEDEP}]
+ >=dev-python/terminado-0.8.3[${PYTHON_USEDEP}]
+ >=dev-python/tornado-6.2[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-5.6.0[${PYTHON_USEDEP}]
+ dev-python/websocket-client[${PYTHON_USEDEP}]
+
+"
+BDEPEND="
+ test? (
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/flaky[${PYTHON_USEDEP}]
+ dev-python/pytest-console-scripts[${PYTHON_USEDEP}]
+ dev-python/pytest-jupyter[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/pytest-tornasync[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # This fails if your terminal is zsh (and maybe other non-bash as well?)
+ tests/test_terminal.py
+ # Fails because above is ignored
+ tests/auth/test_authorizer.py
+ # Fails with additional extensions installed
+ tests/extension/test_app.py::test_stop_extension
+)
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.0.1-skip-npm.patch"
+)
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest \
+ -p pytest_tornasync.plugin \
+ -p jupyter_server.pytest_plugin \
+ -p pytest_console_scripts \
+ -p pytest_timeout
+}