summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2022-05-05 16:02:22 -0700
committerPatrick McLean <chutzpah@gentoo.org>2022-05-05 16:02:40 -0700
commitd9affd0d063352a588dbd7419a4fa9da13644d2a (patch)
tree692506e3de882991297baaad6dc3cbb4a5258766 /dev-python/jsonschema
parentsys-cluster/ceph: Fix rados-classes path (bug #842822) (diff)
downloadgentoo-d9affd0d063352a588dbd7419a4fa9da13644d2a.tar.gz
gentoo-d9affd0d063352a588dbd7419a4fa9da13644d2a.tar.bz2
gentoo-d9affd0d063352a588dbd7419a4fa9da13644d2a.zip
dev-python/jsonschema: add 4.5.1
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/jsonschema')
-rw-r--r--dev-python/jsonschema/Manifest1
-rw-r--r--dev-python/jsonschema/jsonschema-4.5.1.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/jsonschema/Manifest b/dev-python/jsonschema/Manifest
index 2c484f637935..2b035efe4cd7 100644
--- a/dev-python/jsonschema/Manifest
+++ b/dev-python/jsonschema/Manifest
@@ -1 +1,2 @@
DIST jsonschema-4.4.0.tar.gz 313519 BLAKE2B 6339c4ac9e99b55e41c133861baacb6644e04d15e915d3199955512530c946973ca6d5348746688660ea7392d53102754dba3f3380fc8aa3a4ab284a9dcde684 SHA512 8e5c138f4debf7540e2cd131f3f208d1778927ac9036f5fa67bcf5db8c62fe1bb454c7818ee61acef64e856ea4b498ef6ab08be314a3c6b1e461e0bb44db41c7
+DIST jsonschema-4.5.1.tar.gz 282414 BLAKE2B 5b1d4e591e48c760e89a438b3bf9ea6b27b0959030be4558d5a863ceea218bdc4db19d09e2783724026fc2e10eeb6c969a939f4d1a5b44c16dbf7ff39c61a743 SHA512 3866a649ece45c1c69d3d5e9810cfdb094f1af82fcc08a186f9babd7516ad311c4bffa52f61f013bc84e7ab1be06605c5fab738c1c920ff8ce85a73429d9efde
diff --git a/dev-python/jsonschema/jsonschema-4.5.1.ebuild b/dev-python/jsonschema/jsonschema-4.5.1.ebuild
new file mode 100644
index 000000000000..41072af7dd9d
--- /dev/null
+++ b/dev-python/jsonschema/jsonschema-4.5.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="An implementation of JSON-Schema validation for Python"
+HOMEPAGE="
+ https://pypi.org/project/jsonschema/
+ https://github.com/python-jsonschema/jsonschema/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/attrs[${PYTHON_USEDEP}]
+ >=dev-python/pyrsistent-0.18.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/importlib_resources-1.4.0[${PYTHON_USEDEP}]
+ ' 3.8)
+"
+
+# formatter deps
+RDEPEND+="
+ dev-python/fqdn[${PYTHON_USEDEP}]
+ dev-python/idna[${PYTHON_USEDEP}]
+ dev-python/isoduration[${PYTHON_USEDEP}]
+ >=dev-python/jsonpointer-1.13[${PYTHON_USEDEP}]
+ dev-python/rfc3339-validator[${PYTHON_USEDEP}]
+ dev-python/rfc3986-validator[${PYTHON_USEDEP}]
+ dev-python/rfc3987[${PYTHON_USEDEP}]
+ dev-python/uri_template[${PYTHON_USEDEP}]
+ >=dev-python/webcolors-1.11[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # requires pip, does not make much sense for the users
+ jsonschema/tests/test_cli.py::TestCLIIntegration::test_license
+ # wtf?
+ jsonschema/tests/test_deprecations.py::TestDeprecations::test_version
+)