summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-20 17:24:50 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-20 17:37:44 +0200
commitc60c91cdeb624ef9b31b3ace4f5eb5ec55896692 (patch)
tree31f0edd4b268eaa0bede17ec4182c498ef5edd60 /dev-python/jaraco-packaging
parentpackage.mask: Last rite {dev-python/backports..lru-cache,/enum34} (diff)
downloadgentoo-c60c91cdeb624ef9b31b3ace4f5eb5ec55896692.tar.gz
gentoo-c60c91cdeb624ef9b31b3ace4f5eb5ec55896692.tar.bz2
gentoo-c60c91cdeb624ef9b31b3ace4f5eb5ec55896692.zip
dev-python/jaraco-packaging: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jaraco-packaging')
-rw-r--r--dev-python/jaraco-packaging/Manifest1
-rw-r--r--dev-python/jaraco-packaging/jaraco-packaging-6.2-r1.ebuild60
2 files changed, 0 insertions, 61 deletions
diff --git a/dev-python/jaraco-packaging/Manifest b/dev-python/jaraco-packaging/Manifest
index 3d2770628d9d..d0bd6c836512 100644
--- a/dev-python/jaraco-packaging/Manifest
+++ b/dev-python/jaraco-packaging/Manifest
@@ -1,2 +1 @@
-DIST jaraco.packaging-6.2.tar.gz 15408 BLAKE2B 21c63b4e400bdf8b4b79873e6a96c7576b91500624c942246a8f64fc06da22e90203832c3c3084803c6ee23af8f102bb23cb12276cd3bba13446815f4a71f0dc SHA512 f8496a9dccb29dbac24927b40bc29d472b8c6bdb939bfcacf70196130ba9c961747a8b75c63574352a8bfeb2a512eb849dfba3344e942f1338ea1538e0767f33
DIST jaraco.packaging-8.1.0.tar.gz 15322 BLAKE2B c354bec458a319bd9df0667c155203efa5c3de2d95218d0dd3a5878011d2d8fef694a490a2bac0035bff8daa18d1a3447c2c8dab7c0bd7bb09b62969f91d4709 SHA512 99996765cb047f2f0416d6afc4ff6ee0d84d03da0e07c7a7121518fbaf668f587c044f567c1d66a455372897ec1634ba5ee490552ac92064ca072e20b8f60a3b
diff --git a/dev-python/jaraco-packaging/jaraco-packaging-6.2-r1.ebuild b/dev-python/jaraco-packaging/jaraco-packaging-6.2-r1.ebuild
deleted file mode 100644
index 0b66c5cd54c0..000000000000
--- a/dev-python/jaraco-packaging/jaraco-packaging-6.2-r1.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( pypy3 python{2_7,3_{6,7,8}} )
-
-inherit distutils-r1
-
-MY_PN="${PN/-/.}"
-DESCRIPTION="Tools to supplement packaging Python releases"
-HOMEPAGE="https://github.com/jaraco/jaraco.packaging"
-SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 s390 sparc x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/importlib_metadata[${PYTHON_USEDEP}]
- >=dev-python/namespace-jaraco-2[${PYTHON_USEDEP}]
- >=dev-python/six-1.4[${PYTHON_USEDEP}]
-"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- ${RDEPEND}
- >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_sphinx docs \
- ">=dev-python/rst-linker-1.9"
-
-python_prepare_all() {
- # avoid a setuptools_scm dependency
- sed -i "s:use_scm_version=True:version='${PV}',name='${PN//-/.}':" setup.py || die
- sed -r -i "s:setuptools_scm[[:space:]]*([><=]{1,2}[[:space:]]*[0-9.a-zA-Z]+)[[:space:]]*::" \
- setup.cfg || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- # Skip one test which requires network access
- # Override pytest options to skip flake8
- PYTHONPATH=. pytest -vv -k "not test_revived_distribution" \
- --override-ini="addopts=--doctest-modules" \
- || die "tests failed with ${EPYTHON}"
-}
-
-# https://wiki.gentoo.org/wiki/Project:Python/Namespace_packages#File_collisions_between_pkgutil-style_packages
-python_install() {
- rm "${BUILD_DIR}"/lib/jaraco/__init__.py || die
- # note: eclass may default to --skip-build in the future
- distutils-r1_python_install --skip-build
-}