summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-22 10:42:33 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-22 10:42:33 +0100
commit3a7606484df69f6880eca6a92ef40bfb99902886 (patch)
tree51d5691cff598c6283cb3deb4884fe6f52fab38f /dev-python/ipywidgets
parentdev-python/httpbin: Bump to EAPI 8 / PEP517 (diff)
downloadgentoo-3a7606484df69f6880eca6a92ef40bfb99902886.tar.gz
gentoo-3a7606484df69f6880eca6a92ef40bfb99902886.tar.bz2
gentoo-3a7606484df69f6880eca6a92ef40bfb99902886.zip
dev-python/ipywidgets: Remove unnecessary jupyterlab_widgets dep
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/ipywidgets')
-rw-r--r--dev-python/ipywidgets/ipywidgets-7.6.5-r2.ebuild (renamed from dev-python/ipywidgets/ipywidgets-7.6.5-r1.ebuild)7
1 files changed, 7 insertions, 0 deletions
diff --git a/dev-python/ipywidgets/ipywidgets-7.6.5-r1.ebuild b/dev-python/ipywidgets/ipywidgets-7.6.5-r2.ebuild
index d5960928a26b..ef21542a3c78 100644
--- a/dev-python/ipywidgets/ipywidgets-7.6.5-r1.ebuild
+++ b/dev-python/ipywidgets/ipywidgets-7.6.5-r2.ebuild
@@ -30,3 +30,10 @@ distutils_enable_tests pytest
PATCHES=(
"${FILESDIR}/${PN}-7.6.3-py310.patch"
)
+
+src_prepare() {
+ # upstream hack to autoconfigure ipywidgets in jupyter
+ # we don't have jupyterlab_widgets packaged
+ sed -i -e '/jupyterlab_widgets/d' setup.py || die
+ distutils-r1_src_prepare
+}