summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-24 07:24:51 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-24 07:24:51 +0200
commitf0beb8f2a8518b2dce29b413df77e42f2f9a628e (patch)
tree1c5968a72e3168fb0245fef90e6226dec9cec5bc /dev-python/ini2toml
parentdev-python/jaraco-envs: Bump to 2.6.0 (diff)
downloadgentoo-f0beb8f2a8518b2dce29b413df77e42f2f9a628e.tar.gz
gentoo-f0beb8f2a8518b2dce29b413df77e42f2f9a628e.tar.bz2
gentoo-f0beb8f2a8518b2dce29b413df77e42f2f9a628e.zip
dev-python/ini2toml: Bump to 0.13
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/ini2toml')
-rw-r--r--dev-python/ini2toml/Manifest1
-rw-r--r--dev-python/ini2toml/ini2toml-0.13.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/ini2toml/Manifest b/dev-python/ini2toml/Manifest
index 552479755106..76a995c358de 100644
--- a/dev-python/ini2toml/Manifest
+++ b/dev-python/ini2toml/Manifest
@@ -1 +1,2 @@
DIST ini2toml-0.12.tar.gz 101098 BLAKE2B 8e44600718318ce9c2ebaa5205864c1ca6ce87852a59496801578f32e223b9283d2f724acf004136743f87c8a081e58fd1176abe85288f8c463fc2520f708633 SHA512 c324a65fa20af880f2731b740dbf041ef7673d7ab817a9ee1947bf781d39bc000fcd8a725a546fc6af0dbecd0ec0534b2f9b83f3d8ab4afc0239d94acca06df5
+DIST ini2toml-0.13.tar.gz 102729 BLAKE2B 27094e0f329ce5d0da3ca1793b5b92e97eba5068225c55fcc9e0c61ead607967b8718976bfa13f76638c1b2bd8ee2a532b8eaf2023895f2ffdeacacd072fff9c SHA512 9700affeeb0434699e708fbeffb34e68f54882d7c5ada25cbdcdf47fed70bf8b5e8ff46503c19aa135079bc8770bdc48e991212b07b6409adf57d197a5ed998e
diff --git a/dev-python/ini2toml/ini2toml-0.13.ebuild b/dev-python/ini2toml/ini2toml-0.13.ebuild
new file mode 100644
index 000000000000..737ed94cbe5b
--- /dev/null
+++ b/dev-python/ini2toml/ini2toml-0.13.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Automatically conversion of .ini/.cfg files to TOML equivalents"
+HOMEPAGE="
+ https://pypi.org/project/ini2toml/
+ https://github.com/abravalheri/ini2toml/
+"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/packaging-20.7[${PYTHON_USEDEP}]
+ >=dev-python/setuptools-59.6[${PYTHON_USEDEP}]
+ >=dev-python/tomli-w-0.4.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/configupdater[${PYTHON_USEDEP}]
+ >=dev-python/pyproject-fmt-0.4.0[${PYTHON_USEDEP}]
+ dev-python/tomli[${PYTHON_USEDEP}]
+ dev-python/tomlkit[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # validate_pyproject is not packaged
+ tests/test_examples.py
+)
+
+src_prepare() {
+ sed -i -e 's:--cov ini2toml --cov-report term-missing::' setup.cfg || die
+ distutils-r1_src_prepare
+}