summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-26 02:47:51 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-26 04:09:26 +0200
commit234e5fbbb44bbc9e78d97c94a1a89935e206de91 (patch)
tree70cb3588d210842e6f28c5235a80b6b70e748db8 /dev-python/hypothesis
parentapp-admin/awscli: Bump to 1.33.15 (diff)
downloadgentoo-234e5fbbb44bbc9e78d97c94a1a89935e206de91.tar.gz
gentoo-234e5fbbb44bbc9e78d97c94a1a89935e206de91.tar.bz2
gentoo-234e5fbbb44bbc9e78d97c94a1a89935e206de91.zip
dev-python/hypothesis: Bump to 6.104.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/hypothesis')
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-6.104.1.ebuild103
2 files changed, 104 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index dfcab6d76324..6b87fefbe956 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -3,3 +3,4 @@ DIST hypothesis-6.103.1.gh.tar.gz 9463631 BLAKE2B 7c7df97ff5702103c3e02d664732cd
DIST hypothesis-6.103.2.gh.tar.gz 9463865 BLAKE2B d14882642edf53354a6cc8bdf4fb8ac3a5e93a6d5387186e2bd442447710a3e0e84dc61dee6febb690e85552ec3642df58fb731287a6ffd4fc59bd0c69f4f6a9 SHA512 e18ed2ee70541bf992aae784bed59e4e9b1cd784f2bc35573d3a375fcc749bd0a756b7a2a494a16a04ffca386034bab6f99ae0e25ddb18542af0754df081a359
DIST hypothesis-6.103.5.gh.tar.gz 9465630 BLAKE2B c85fa7a5fb62db9903fc8c1641b2e58628bab96561239d4df00202475272da817139d7aa3de68ad064bfdb65a8effade71e2f1efb550f1792028b4f79193f572 SHA512 705383cdf6f9e9fc69dd5e967adef13e7712be207f7ff58368d9f03bb2e41009e1853d01db6beb19c8b65f44d33123932e1d2cf1c7a09e31498ba05234c48798
DIST hypothesis-6.104.0.gh.tar.gz 9466479 BLAKE2B 9cf9f28d3ad739a40062369a37ea423df4b10101d43c54e62ab395bbce970f6500aa09f2bebbb55145488a979616407cd7b35f28336d6657e585782de72ebe9b SHA512 5823ed6ac3461bc6612e93cbeb74453cef902add4c8db09a98459ac056c8689382cbb007a035c27f215057a635e74bda7e32835d442e218ccabd6c477bbd3ae8
+DIST hypothesis-6.104.1.gh.tar.gz 9466716 BLAKE2B 5ddefd5199bfb22ef8c2c2ae995de5353e7d067f044788f4cd9423cfa4674ff1c5a05760d686f4b4dd5fe9afb2b4ba1cdb38aa7d590575f79d75c460adde63ab SHA512 a9eef39e3cc8fde806cb860f47190239a680c3203ca0228450a7c999ee9618964e201c05a994835e5513f7945b3a5f830fd9fa941d4cfdf4793e5e2fb266df47
diff --git a/dev-python/hypothesis/hypothesis-6.104.1.ebuild b/dev-python/hypothesis/hypothesis-6.104.1.ebuild
new file mode 100644
index 000000000000..d401f55b2788
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-6.104.1.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+CLI_COMPAT=( pypy3 python3_{10..13} )
+PYTHON_COMPAT=( "${CLI_COMPAT[@]}" )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 optfeature
+
+TAG=hypothesis-python-${PV}
+MY_P=hypothesis-${TAG}
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="
+ https://github.com/HypothesisWorks/hypothesis/
+ https://pypi.org/project/hypothesis/
+"
+SRC_URI="
+ https://github.com/HypothesisWorks/hypothesis/archive/${TAG}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/${MY_P}/hypothesis-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="cli"
+
+RDEPEND="
+ >=dev-python/attrs-22.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/exceptiongroup-1.0.0_rc8[${PYTHON_USEDEP}]
+ ' 3.9 3.10)
+ cli? (
+ $(python_gen_cond_dep '
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ ' "${CLI_COMPAT[@]}")
+ )
+"
+BDEPEND="
+ test? (
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ >=dev-python/pytest-8[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ !!<dev-python/requests-toolbelt-0.10.1
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_test() {
+ # subtests are broken by warnings from random plugins
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=xdist.plugin,_hypothesis_pytestplugin
+ local -x HYPOTHESIS_NO_PLUGINS=1
+
+ # NB: paths need to be relative to pytest.ini,
+ # i.e. start with hypothesis-python/
+ local EPYTEST_DESELECT=()
+ case ${EPYTHON} in
+ pypy3)
+ EPYTEST_DESELECT+=(
+ # failing due to warnings from numpy/cython
+ hypothesis-python/tests/pytest/test_fixtures.py::test_given_plus_overridden_fixture
+ )
+ ;;
+ esac
+
+ epytest -o filterwarnings= tests/cover tests/pytest tests/quality
+}
+
+src_install() {
+ local HAD_CLI=
+
+ distutils-r1_src_install
+
+ if [[ ! ${HAD_CLI} ]]; then
+ rm -r "${ED}/usr/bin" || die
+ fi
+}
+
+python_install() {
+ distutils-r1_python_install
+ if use cli && has "${EPYTHON}" "${CLI_COMPAT[@]/_/.}"; then
+ HAD_CLI=1
+ else
+ rm -r "${D}$(python_get_scriptdir)" || die
+ fi
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}