summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-29 04:55:12 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-29 05:01:00 +0200
commit2a68b40c3c5ab1e244516f332e1f74f7eab47573 (patch)
tree8091def2c4c1118b99a5532f8b17d6432f9fa963 /dev-python/gsd
parentsci-libs/rocSOLVER: disable all the non-FHS symlinks. (diff)
downloadgentoo-2a68b40c3c5ab1e244516f332e1f74f7eab47573.tar.gz
gentoo-2a68b40c3c5ab1e244516f332e1f74f7eab47573.tar.bz2
gentoo-2a68b40c3c5ab1e244516f332e1f74f7eab47573.zip
dev-python/gsd: Bump to 3.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/gsd')
-rw-r--r--dev-python/gsd/Manifest1
-rw-r--r--dev-python/gsd/gsd-3.1.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/gsd/Manifest b/dev-python/gsd/Manifest
index 4c24c391f4d6..a3d5b5d8bc1c 100644
--- a/dev-python/gsd/Manifest
+++ b/dev-python/gsd/Manifest
@@ -1 +1,2 @@
DIST gsd-3.0.1.tar.gz 106692 BLAKE2B d65b4bda7ffbba315f83a4cda8188181616a1a351d6848b91984ac97b404e5f134be567c3c616c7ff31a1402f828d76658c59b6fedeb6bcd32667ce6c7135518 SHA512 011f640aaf14e685edabd4438c93c2821cd056ba98bf2b29d3f207bf0384ccb0745580c07e1dea98790667d81d69f74b7a9a6efb019def236b515f76895a84fe
+DIST gsd-3.1.0.tar.gz 106081 BLAKE2B a3c1a13c4c733aa0f46b4f0ecd92c7055036ecee0b63d755b84f6b62d04401295cb403151bb1460a95b94d7f46abf9d8bc5b33d627cc7b15444a3478eee35651 SHA512 68a096e44584683eeff0ac13037388ffe9c8c680e371a7a1bfeff84df937a3b4860cad15a42c4766c338da59e6a9393f92a83f2546f00e0c0d013648fac50273
diff --git a/dev-python/gsd/gsd-3.1.0.ebuild b/dev-python/gsd/gsd-3.1.0.ebuild
new file mode 100644
index 000000000000..c9851b2e7559
--- /dev/null
+++ b/dev-python/gsd/gsd-3.1.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="GSD - file format specification and a library to read and write it"
+HOMEPAGE="
+ https://github.com/glotzerlab/gsd/
+ https://pypi.org/project/gsd/
+"
+SRC_URI="
+ https://github.com/glotzerlab/gsd/releases/download/v${PV}/${P}.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ >=dev-python/numpy-1.24.2[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ cd "${T}" || die
+ epytest --pyargs gsd
+}