summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-06 19:47:10 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-06 20:12:13 +0200
commited6287f5721415a780890134e7fdff08ba2b5f2f (patch)
tree3bcaae5764bf2d1b9971a56031e216ab0941d9c5 /dev-python/google-auth
parentdev-python/cfn-lint: Remove old (diff)
downloadgentoo-ed6287f5721415a780890134e7fdff08ba2b5f2f.tar.gz
gentoo-ed6287f5721415a780890134e7fdff08ba2b5f2f.tar.bz2
gentoo-ed6287f5721415a780890134e7fdff08ba2b5f2f.zip
dev-python/google-auth: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/google-auth')
-rw-r--r--dev-python/google-auth/Manifest3
-rw-r--r--dev-python/google-auth/files/google-auth-2.20.0-urllib3-2.patch62
-rw-r--r--dev-python/google-auth/google-auth-2.22.0.ebuild63
-rw-r--r--dev-python/google-auth/google-auth-2.23.0.ebuild66
-rw-r--r--dev-python/google-auth/google-auth-2.23.1.ebuild61
5 files changed, 0 insertions, 255 deletions
diff --git a/dev-python/google-auth/Manifest b/dev-python/google-auth/Manifest
index 01d1416097d8..c7f0ebd8953d 100644
--- a/dev-python/google-auth/Manifest
+++ b/dev-python/google-auth/Manifest
@@ -1,4 +1 @@
-DIST google-auth-2.22.0.tar.gz 231433 BLAKE2B 07b813209ce3f5ff429c4f9417141fa85029ff3eedb116664d6effdf508497ce6b6552fa4c3b6f9f1e7f1ffe9b9ae8ce72c8c727d277662bb9f8214ccd152b66 SHA512 c2c04e9ad367dd96bf00af7b19c7d897dd9fe3f8e9318b7436ec85a5c146b29c273cc718932956e97b2e4a1e2f12d0d10e835b6cf0f4e46ee19f6aaeed492b5e
-DIST google-auth-2.23.0.tar.gz 231512 BLAKE2B fd7594fb28114d07773e2f0bf2da475cb1d771ef27f67765e9235883cd312b88cda092c5bcbb7a1468ded44da4e5cd121c58850058b023232725a9829969b8c3 SHA512 d5c4967478c2a2846f2297b8449cd1a9de9796f3e1a5075ac7a3c2c35a30468fe93bf5c37b7bb4305925fe5097a57fddbddc482be4446e4364a78709eec1d8cd
-DIST google-auth-2.23.1.tar.gz 232191 BLAKE2B ce828a3f04993cfd4746c096b70b5813e60acd8ed56ffc87f608f4a33a465eba4cc52a58906a7d5aeed787bf4b26b8f77fb02294181e61ed69f9036fce34dcb3 SHA512 2d8677cff7c3c6de70a4e6934a78585c098c2f2a8ca3007acb8eb4612b32ffd1ce9c841aa57f9ce043fab071dddf3bef153684541a82a80a5a914d7c377acb9b
DIST google-auth-2.23.2.tar.gz 232207 BLAKE2B 0de53f79bd908d7194253525de07075779ffc0ed33ef71e50004773ba85aee8e7392cd5cc87ad88b5f9ce90bc3eb19c0c094d0e76311d2cd93fb0bdb62ab2450 SHA512 d443b769e6ee7de6da14e31f8beb938aaf63edecafcbedda46b253bf0380dbd78a4508a0214f7a708a09c39d1d262cc93a290ec44e89fa05da7796828f33c1fd
diff --git a/dev-python/google-auth/files/google-auth-2.20.0-urllib3-2.patch b/dev-python/google-auth/files/google-auth-2.20.0-urllib3-2.patch
deleted file mode 100644
index dcaf88d1a288..000000000000
--- a/dev-python/google-auth/files/google-auth-2.20.0-urllib3-2.patch
+++ /dev/null
@@ -1,62 +0,0 @@
-From 9ed006d02d7c9de3e6898ee819648c2fd3367c1d Mon Sep 17 00:00:00 2001
-From: Daniel Garcia Moreno <daniel.garcia@suse.com>
-Date: Wed, 10 May 2023 09:18:57 +0200
-Subject: [PATCH] Support urllib3 >= 2.0.0
-
-The urllib3.request.RequestMethods has been moved to
-urllib3._request_methods.RequestMethods.
-
-This patch changes the usage to continue working with the latest
-release, but now it's a "private" class in a "private" module, so maybe
-it's worth to start to think about updating this code to use the public
-API.
-
-https://urllib3.readthedocs.io/en/stable/changelog.html#removed
----
- google/auth/transport/urllib3.py | 11 ++++++-----
- setup.py | 2 +-
- 2 files changed, 7 insertions(+), 6 deletions(-)
-
-diff --git a/google/auth/transport/urllib3.py b/google/auth/transport/urllib3.py
-index 4abc26b52..f1dd35320 100644
---- a/google/auth/transport/urllib3.py
-+++ b/google/auth/transport/urllib3.py
-@@ -95,8 +95,8 @@ class Request(transport.Request):
- credentials.refresh(request)
-
- Args:
-- http (urllib3.request.RequestMethods): An instance of any urllib3
-- class that implements :class:`~urllib3.request.RequestMethods`,
-+ http (urllib3._request_methods.RequestMethods): An instance of any urllib3
-+ class that implements :class:`~urllib3._request_methods.RequestMethods`,
- usually :class:`urllib3.PoolManager`.
-
- .. automethod:: __call__
-@@ -184,7 +184,7 @@ def _make_mutual_tls_http(cert, key):
- return http
-
-
--class AuthorizedHttp(urllib3.request.RequestMethods):
-+class AuthorizedHttp(urllib3._request_methods.RequestMethods):
- """A urllib3 HTTP class with credentials.
-
- This class is used to perform requests to API endpoints that require
-@@ -197,8 +197,9 @@ class AuthorizedHttp(urllib3.request.RequestMethods):
- response = authed_http.request(
- 'GET', 'https://www.googleapis.com/storage/v1/b')
-
-- This class implements :class:`urllib3.request.RequestMethods` and can be
-- used just like any other :class:`urllib3.PoolManager`.
-+ This class implements
-+ :class:`urllib3._request_methods.RequestMethods` and can be used
-+ just like any other :class:`urllib3.PoolManager`.
-
- The underlying :meth:`urlopen` implementation handles adding the
- credentials' headers to the request and refreshing credentials as needed.
-diff --git a/setup.py b/setup.py
-index e45512a02..cfb3b504f 100644
---- a/setup.py
-+++ b/setup.py
-@@ -32,1 +32,1 @@
-- "urllib3<2.0",
-+ "urllib3>=2.0",
diff --git a/dev-python/google-auth/google-auth-2.22.0.ebuild b/dev-python/google-auth/google-auth-2.22.0.ebuild
deleted file mode 100644
index a3342ef26a76..000000000000
--- a/dev-python/google-auth/google-auth-2.22.0.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYPI_NO_NORMALIZE=1
-PYTHON_COMPAT=( python3_{10..11} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Google Authentication Library"
-HOMEPAGE="
- https://github.com/googleapis/google-auth-library-python/
- https://pypi.org/project/google-auth/
-"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 x86"
-
-RDEPEND="
- <dev-python/cachetools-6.0.0[${PYTHON_USEDEP}]
- >=dev-python/pyasn1-0.1.7[${PYTHON_USEDEP}]
- >=dev-python/pyasn1-modules-0.2.1[${PYTHON_USEDEP}]
- >=dev-python/rsa-3.1.4[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- !dev-python/namespace-google
-"
-BDEPEND="
- test? (
- dev-python/cryptography[${PYTHON_USEDEP}]
- dev-python/flask[${PYTHON_USEDEP}]
- dev-python/freezegun[${PYTHON_USEDEP}]
- dev-python/grpcio[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/moto[${PYTHON_USEDEP}]
- dev-python/pyopenssl[${PYTHON_USEDEP}]
- dev-python/pytest-localserver[${PYTHON_USEDEP}]
- dev-python/pyu2f[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/responses[${PYTHON_USEDEP}]
- >=dev-python/urllib3-2[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-PATCHES=(
- # https://github.com/googleapis/google-auth-library-python/pull/1290
- "${FILESDIR}"/google-auth-2.20.0-urllib3-2.patch
-)
-
-EPYTEST_IGNORE=(
- # these are compatibility tests with oauth2client
- # disable them to unblock removal of that package
- tests/test__oauth2client.py
-)
-
-python_compile() {
- distutils-r1_python_compile
- find "${BUILD_DIR}" -name '*.pth' -delete || die
-}
diff --git a/dev-python/google-auth/google-auth-2.23.0.ebuild b/dev-python/google-auth/google-auth-2.23.0.ebuild
deleted file mode 100644
index 4fb5afb4df60..000000000000
--- a/dev-python/google-auth/google-auth-2.23.0.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYPI_NO_NORMALIZE=1
-PYTHON_COMPAT=( python3_{10..11} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Google Authentication Library"
-HOMEPAGE="
- https://github.com/googleapis/google-auth-library-python/
- https://pypi.org/project/google-auth/
-"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-
-RDEPEND="
- <dev-python/cachetools-6.0.0[${PYTHON_USEDEP}]
- >=dev-python/pyasn1-0.1.7[${PYTHON_USEDEP}]
- >=dev-python/pyasn1-modules-0.2.1[${PYTHON_USEDEP}]
- >=dev-python/rsa-3.1.4[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/cryptography[${PYTHON_USEDEP}]
- dev-python/flask[${PYTHON_USEDEP}]
- dev-python/freezegun[${PYTHON_USEDEP}]
- dev-python/grpcio[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/moto[${PYTHON_USEDEP}]
- dev-python/pyopenssl[${PYTHON_USEDEP}]
- dev-python/pytest-localserver[${PYTHON_USEDEP}]
- dev-python/pyu2f[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/responses[${PYTHON_USEDEP}]
- >=dev-python/urllib3-2[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-PATCHES=(
- # https://github.com/googleapis/google-auth-library-python/pull/1290
- "${FILESDIR}"/google-auth-2.20.0-urllib3-2.patch
-)
-
-python_test() {
- local EPYTEST_IGNORE=(
- # these are compatibility tests with oauth2client
- # disable them to unblock removal of that package
- tests/test__oauth2client.py
- )
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest
-}
-
-python_compile() {
- distutils-r1_python_compile
- find "${BUILD_DIR}" -name '*.pth' -delete || die
-}
diff --git a/dev-python/google-auth/google-auth-2.23.1.ebuild b/dev-python/google-auth/google-auth-2.23.1.ebuild
deleted file mode 100644
index 4cd570591bdc..000000000000
--- a/dev-python/google-auth/google-auth-2.23.1.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYPI_NO_NORMALIZE=1
-PYTHON_COMPAT=( python3_{10..11} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Google Authentication Library"
-HOMEPAGE="
- https://github.com/googleapis/google-auth-library-python/
- https://pypi.org/project/google-auth/
-"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-
-RDEPEND="
- <dev-python/cachetools-6.0.0[${PYTHON_USEDEP}]
- >=dev-python/pyasn1-0.1.7[${PYTHON_USEDEP}]
- >=dev-python/pyasn1-modules-0.2.1[${PYTHON_USEDEP}]
- >=dev-python/rsa-3.1.4[${PYTHON_USEDEP}]
- >=dev-python/urllib3-2.0.5[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/cryptography[${PYTHON_USEDEP}]
- dev-python/flask[${PYTHON_USEDEP}]
- dev-python/freezegun[${PYTHON_USEDEP}]
- dev-python/grpcio[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/moto[${PYTHON_USEDEP}]
- dev-python/pyopenssl[${PYTHON_USEDEP}]
- dev-python/pytest-localserver[${PYTHON_USEDEP}]
- dev-python/pyu2f[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/responses[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_IGNORE=(
- # these are compatibility tests with oauth2client
- # disable them to unblock removal of that package
- tests/test__oauth2client.py
- )
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest
-}
-
-python_compile() {
- distutils-r1_python_compile
- find "${BUILD_DIR}" -name '*.pth' -delete || die
-}