summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-09-10 20:17:05 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2023-09-10 20:25:47 +0300
commit0f1580a00dea83743710833e198e3cf53b1dcef1 (patch)
tree3c81ee39051a5a249cadde02f1c160af4650a8b8 /dev-python/furo
parentwww-apps/prowlarr: drop 1.8.5.3896 (diff)
downloadgentoo-0f1580a00dea83743710833e198e3cf53b1dcef1.tar.gz
gentoo-0f1580a00dea83743710833e198e3cf53b1dcef1.tar.bz2
gentoo-0f1580a00dea83743710833e198e3cf53b1dcef1.zip
dev-python/furo: add 2023.9.10
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/furo')
-rw-r--r--dev-python/furo/Manifest1
-rw-r--r--dev-python/furo/furo-2023.9.10.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/furo/Manifest b/dev-python/furo/Manifest
index 523baf65de11..8df4dddeab40 100644
--- a/dev-python/furo/Manifest
+++ b/dev-python/furo/Manifest
@@ -1 +1,2 @@
DIST furo-2023.8.19-py3-none-any.whl 323684 BLAKE2B 56b05551a4be4e01492a85f25bdb3057dffab4c66a98fc196c8d486ccfab6d8eec86184bc4b99308b3522b4eb21edadfd231aba8c9cdb3ffdcdac7c90e6a5a91 SHA512 6134271db8fb60b1fddfff1af0d4394192251d0942c070c29af29313ff7abd14f46f12823b90e8d56f03c92a22732af0b39f754c513513f2437487c6adb070f8
+DIST furo-2023.9.10-py3-none-any.whl 324431 BLAKE2B 3a513e00c7a5856c19fda8e74c6a66fd89ea53ae5a8035969bc84b3827ec7f8b4c48bf964e3fd9d663f780b4621bdff31cc1bee2ffe0bc8e35700a41e4eb1bcc SHA512 67aba2f451beba1d2ecdcac8cd38db8a5b5952ccdd5d715d8b59ca68106214a8d9b8e0efe3adad6ee1ad84459904053b8fa038d8a334073b4879bd51934c28cf
diff --git a/dev-python/furo/furo-2023.9.10.ebuild b/dev-python/furo/furo-2023.9.10.ebuild
new file mode 100644
index 000000000000..06a7abd71a27
--- /dev/null
+++ b/dev-python/furo/furo-2023.9.10.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# sphinx-theme-builder is completely unusable, as it requires pinning
+# to a very-specific nodejs version number, and ofc loves fetching
+# everything from the Internet
+
+DISTUTILS_USE_PEP517=standalone
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Clean customisable Sphinx documentation theme"
+HOMEPAGE="
+ https://pypi.org/project/furo/
+ https://github.com/pradyunsg/furo/
+"
+SRC_URI="$(pypi_wheel_url)"
+S=${WORKDIR}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx-basic-ng[${PYTHON_USEDEP}]
+"
+
+python_compile() {
+ distutils_wheel_install "${BUILD_DIR}/install" \
+ "${DISTDIR}/${P}-py3-none-any.whl"
+}