summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2019-07-19 00:25:24 +0200
committerLouis Sautier <sbraz@gentoo.org>2019-07-19 00:25:37 +0200
commit0af4d0acb12601bd5eb7bf62fe2d657c1ee56637 (patch)
treedd75310961e7e26a9acedd243156cadc0cb67abc /dev-python/flask-paginate/flask-paginate-0.5.3-r1.ebuild
parentwww-client/qutebrowser: bump 1.7.0 (diff)
downloadgentoo-0af4d0acb12601bd5eb7bf62fe2d657c1ee56637.tar.gz
gentoo-0af4d0acb12601bd5eb7bf62fe2d657c1ee56637.tar.bz2
gentoo-0af4d0acb12601bd5eb7bf62fe2d657c1ee56637.zip
dev-python/flask-paginate: add PyPy{,3}, fix test dependencies
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'dev-python/flask-paginate/flask-paginate-0.5.3-r1.ebuild')
-rw-r--r--dev-python/flask-paginate/flask-paginate-0.5.3-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/flask-paginate/flask-paginate-0.5.3-r1.ebuild b/dev-python/flask-paginate/flask-paginate-0.5.3-r1.ebuild
new file mode 100644
index 000000000000..1cdce8d7c42b
--- /dev/null
+++ b/dev-python/flask-paginate/flask-paginate-0.5.3-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy{,3} python{2_7,3_{5,6,7}} )
+
+inherit distutils-r1
+
+MY_COMMIT="510ad833106134711868653fb597bf75ea8ac34f"
+
+DESCRIPTION="Pagination support for flask"
+HOMEPAGE="https://flask-paginate.readthedocs.io"
+# https://github.com/lixxu/flask-paginate/issues/68
+SRC_URI="https://github.com/lixxu/flask-paginate/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/flask[${PYTHON_USEDEP}]"
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+
+S="${WORKDIR}/${PN}-${MY_COMMIT}"
+
+python_test() {
+ pytest -vv tests/tests.py || die "tests failed with ${EPYTHON}"
+}