summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/enzyme
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/enzyme')
-rw-r--r--dev-python/enzyme/Manifest2
-rw-r--r--dev-python/enzyme/enzyme-0.4.1.ebuild42
-rw-r--r--dev-python/enzyme/enzyme-9999.ebuild42
-rw-r--r--dev-python/enzyme/metadata.xml13
4 files changed, 99 insertions, 0 deletions
diff --git a/dev-python/enzyme/Manifest b/dev-python/enzyme/Manifest
new file mode 100644
index 000000000000..a5f026ad479a
--- /dev/null
+++ b/dev-python/enzyme/Manifest
@@ -0,0 +1,2 @@
+DIST enzyme-0.4.1.tar.gz 47953 SHA256 f2167fa97c24d1103a94d4bf4eb20f00ca76c38a37499821049253b2059c62bb SHA512 62a85c076a7eb320249a507dcc9dd26572e3a9b9643e0a960ed114a80c75213e6e5028a726fbcdd0c2c46c53af980a69828a54a66af9a17af3210273376395b3 WHIRLPOOL 5055306ce3747b1aa2f6a9bf5ac85c705426e1eaa1e946780f626cbda2cf26d508baf9f6781faeb62d09266df00e6b2c7942493d9139e82eda502cc175cb711c
+DIST matroska_test_w1_1.zip 184550509 SHA256 d86f96e165e695e6cf5324ebca184f2df723872f02965b565820d265b53004eb SHA512 f170a8e83dab15228f992b3692330163da2402b8e436c7fa195ac1ecc06cf1eaf1a48d8c99a85c031122c158c2d4006023aae75d5b7805385ba25a6d601cb78f WHIRLPOOL 3d0a16871fc7df0a3ef3f34f7c496eff188400a9796a2ad66667112ef0de7deecf025196898bd24ea395f8c44e75156a8b8c09d40a92e98d833d995473eefa9e
diff --git a/dev-python/enzyme/enzyme-0.4.1.ebuild b/dev-python/enzyme/enzyme-0.4.1.ebuild
new file mode 100644
index 000000000000..0e9b9962fbe9
--- /dev/null
+++ b/dev-python/enzyme/enzyme-0.4.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python video metadata parser"
+HOMEPAGE="https://github.com/Diaoul/enzyme https://pypi.python.org/pypi/enzyme"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz
+ test? ( http://downloads.sourceforge.net/project/matroska/test_files/matroska_test_w1_1.zip )"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ )
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+python_prepare_all() {
+ if use test; then
+ mkdir enzyme/tests/test_{parsers,mkv} || die
+ ln -s "${WORKDIR}"/test* enzyme/tests/test_parsers/ || die
+ ln -s "${WORKDIR}"/test* enzyme/tests/test_mkv/ || die
+ fi
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ esetup.py test
+}
diff --git a/dev-python/enzyme/enzyme-9999.ebuild b/dev-python/enzyme/enzyme-9999.ebuild
new file mode 100644
index 000000000000..51ac2e149435
--- /dev/null
+++ b/dev-python/enzyme/enzyme-9999.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+EGIT_REPO_URI="https://github.com/Diaoul/enzyme.git"
+
+inherit distutils-r1 git-2
+
+DESCRIPTION="Python video metadata parser"
+HOMEPAGE="https://github.com/Diaoul/enzyme https://pypi.python.org/pypi/enzyme"
+SRC_URI="test? ( http://downloads.sourceforge.net/project/matroska/test_files/matroska_test_w1_1.zip )"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS=""
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ )
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+python_prepare_all() {
+ if use test; then
+ mkdir enzyme/tests/test_{parsers,mkv} || die
+ ln -s "${WORKDIR}"/test* enzyme/tests/test_parsers/ || die
+ ln -s "${WORKDIR}"/test* enzyme/tests/test_mkv/ || die
+ fi
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ esetup.py test
+}
diff --git a/dev-python/enzyme/metadata.xml b/dev-python/enzyme/metadata.xml
new file mode 100644
index 000000000000..83efd6259c51
--- /dev/null
+++ b/dev-python/enzyme/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>nikoli@gmx.us</email>
+ <name>Nikoli</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">enzyme</remote-id>
+ <remote-id type="github">Diaoul/enzyme</remote-id>
+ </upstream>
+</pkgmetadata>