summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-19 20:33:32 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-19 21:56:14 +0200
commit2b90b729ea926492e8ea4b2bcc932f37b8099501 (patch)
tree1a3121bb1456b60a633d493ca46da0e94c09b6c6 /dev-python/django-crispy-forms
parentdev-python/nbxmpp: Bump to 5.0.2 (diff)
downloadgentoo-2b90b729ea926492e8ea4b2bcc932f37b8099501.tar.gz
gentoo-2b90b729ea926492e8ea4b2bcc932f37b8099501.tar.bz2
gentoo-2b90b729ea926492e8ea4b2bcc932f37b8099501.zip
dev-python/django-crispy-forms: Bump to 2.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/django-crispy-forms')
-rw-r--r--dev-python/django-crispy-forms/Manifest1
-rw-r--r--dev-python/django-crispy-forms/django-crispy-forms-2.3.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/django-crispy-forms/Manifest b/dev-python/django-crispy-forms/Manifest
index 87ca176836ec..c2ed000905bf 100644
--- a/dev-python/django-crispy-forms/Manifest
+++ b/dev-python/django-crispy-forms/Manifest
@@ -1 +1,2 @@
DIST django-crispy-forms-2.2.gh.tar.gz 274957 BLAKE2B bb80affa2050c1eee3bb706ab5fc48555676cf118b78ff4d28031c1df9c0e8adba9f1638cbea7f87c4edd2d655fb1a00de30b64e073b1f0f9b35a6103d9b9c08 SHA512 a379fbd1b9916aa3123a4c1af5c9da4916573c57b2e575cb189fe8cba23718490c9130ff55e7ae80dbb3d9476d449daf1f8c9f8caec80f394601af6246615f24
+DIST django-crispy-forms-2.3.gh.tar.gz 274969 BLAKE2B 0a9c24c4aec43b35fd9596c1e23bb5e3988b36398f50a7155360929c41a6e0fdb388ae3c12673fc761c91f0315195f69389d021aef94c2b14a245c706f328599 SHA512 1c5ad8a64a6f8175a6d5eb56b244d856c8aab1ebcc8c4b549aebfa4711128d1401ad0f625ca68c10fb1b0be9656c662e865e783994f323f87e5b08da4bd0585a
diff --git a/dev-python/django-crispy-forms/django-crispy-forms-2.3.ebuild b/dev-python/django-crispy-forms/django-crispy-forms-2.3.ebuild
new file mode 100644
index 000000000000..5d9598bb0f6b
--- /dev/null
+++ b/dev-python/django-crispy-forms/django-crispy-forms-2.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="DRY Django forms"
+HOMEPAGE="
+ https://github.com/django-crispy-forms/django-crispy-forms/
+ https://pypi.org/project/django-crispy-forms/
+"
+SRC_URI="
+ https://github.com/django-crispy-forms/django-crispy-forms/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/django-4.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+ dev-python/crispy-bootstrap3[${PYTHON_USEDEP}]
+ dev-python/crispy-bootstrap4[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest