summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-16 05:43:46 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-16 05:43:46 +0200
commit1c4f3717c8b72f67cb095e09e9daa545d85d8795 (patch)
treeeba05f5d96024318235dc535247365f6882d30c6 /dev-python/django-crispy-forms
parentdev-python/astroid: Bump to 3.0.1 (diff)
downloadgentoo-1c4f3717c8b72f67cb095e09e9daa545d85d8795.tar.gz
gentoo-1c4f3717c8b72f67cb095e09e9daa545d85d8795.tar.bz2
gentoo-1c4f3717c8b72f67cb095e09e9daa545d85d8795.zip
dev-python/django-crispy-forms: Bump to 2.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/django-crispy-forms')
-rw-r--r--dev-python/django-crispy-forms/Manifest1
-rw-r--r--dev-python/django-crispy-forms/django-crispy-forms-2.1.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/django-crispy-forms/Manifest b/dev-python/django-crispy-forms/Manifest
index 50f56cfb5aa8..811c44aa2529 100644
--- a/dev-python/django-crispy-forms/Manifest
+++ b/dev-python/django-crispy-forms/Manifest
@@ -1 +1,2 @@
DIST django-crispy-forms-2.0.gh.tar.gz 273743 BLAKE2B 4169c4f77ddd0dd9f8786abd71ad762f645283555f250861f32b874fb9e189d4ca174285ee39b51bc5f0c0e8c2e83c2e00c34398c51ede65438a1c6b8a17c3ee SHA512 8b6f5b35cb90837b7cd6a64ed74afe6a19a80f287f66d0a139811990524e1a48d4d7c01e61fb7d303958522c47458d0aa0008a3d6c147f7d03dc790e53a80592
+DIST django-crispy-forms-2.1.gh.tar.gz 274397 BLAKE2B 3f38830f370efde04494add3ddd2ce7f4a04b032b9aad770ba30885ed2b3a14cff3c748fa299041c9c1d7007b30eb55c96a46fe496c0432b187ae72879d4240e SHA512 703f353adc272905b4d5ebe21ea54e3016a3889703bf406dfdf92638dac2e6f536cf1bc16022be6a442f7dfa962ff17746edea591cf80c2be9440d9bb50a9dcc
diff --git a/dev-python/django-crispy-forms/django-crispy-forms-2.1.ebuild b/dev-python/django-crispy-forms/django-crispy-forms-2.1.ebuild
new file mode 100644
index 000000000000..c0cf44d4343e
--- /dev/null
+++ b/dev-python/django-crispy-forms/django-crispy-forms-2.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="DRY Django forms"
+HOMEPAGE="
+ https://github.com/django-crispy-forms/django-crispy-forms/
+ https://pypi.org/project/django-crispy-forms/
+"
+SRC_URI="
+ https://github.com/django-crispy-forms/django-crispy-forms/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/django-4.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+ dev-python/crispy-bootstrap3[${PYTHON_USEDEP}]
+ dev-python/crispy-bootstrap4[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest