summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2021-07-30 22:01:45 +0200
committerSebastian Pipping <sping@gentoo.org>2021-07-30 22:03:11 +0200
commit4f5c1bbbc98b4faf85f82ba7b69cfcd314af5a9b (patch)
tree3a3d91f3ed7f60ecd3695a8087daff41d84af391 /dev-python/distro
parentx11-drivers/nvidia-drivers: adjust kms helper message for wayland (diff)
downloadgentoo-4f5c1bbbc98b4faf85f82ba7b69cfcd314af5a9b.tar.gz
gentoo-4f5c1bbbc98b4faf85f82ba7b69cfcd314af5a9b.tar.bz2
gentoo-4f5c1bbbc98b4faf85f82ba7b69cfcd314af5a9b.zip
dev-python/distro: 1.6.0
Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-3.0.20, Repoman-3.0.3
Diffstat (limited to 'dev-python/distro')
-rw-r--r--dev-python/distro/Manifest1
-rw-r--r--dev-python/distro/distro-1.6.0.ebuild17
2 files changed, 18 insertions, 0 deletions
diff --git a/dev-python/distro/Manifest b/dev-python/distro/Manifest
index ab8dbce84230..ec9a1240101e 100644
--- a/dev-python/distro/Manifest
+++ b/dev-python/distro/Manifest
@@ -1 +1,2 @@
DIST distro-1.5.0.tar.gz 54340 BLAKE2B 2a5bf45cdf41b9772a2e164aebe96a4e9952893b7462935938fa4939704c8dca67acc3e0a52e53d8722aa4405abdc7ad2c8d600dd397d1243bcceda4d5ceeb75 SHA512 14831fe1355e9ef4f58f273ce4a548a3fe438e95466b4b4f596b8110da51305d66ed77c2e40c3dbfbcbd1a66c74e23a4d4244c8bfdebc4b49b3e7ddcbff55b8f
+DIST distro-1.6.0.tar.gz 53518 BLAKE2B d60555488ed12658a3129747eed891487dfdf7f16b530b84c44cd976c6dcfadbeb9e20130e5c2eee9c71b0fd0c86c82d258a76498171f4e553c087840903e3b8 SHA512 d30334ed1137c54ddc70e041b75be905b7e13398483d0d92117eca0407d2a7b60424d96fd7af885a2e3ea3676b1aef620e91598a53309ae0da12a360d57ac013
diff --git a/dev-python/distro/distro-1.6.0.ebuild b/dev-python/distro/distro-1.6.0.ebuild
new file mode 100644
index 000000000000..331acc2c9903
--- /dev/null
+++ b/dev-python/distro/distro-1.6.0.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Reliable machine-readable Linux distribution information for Python"
+HOMEPAGE="https://distro.readthedocs.io/en/latest/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+distutils_enable_tests pytest